BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi to all I'm new to forum. My question has any one out there ever fried their wiring harness? I have 03 LT and built a trailer to tow and wired it into the lighting system. Used wiring harness provided by hitch manufacturer. It came with one micro relay for brake lights. It all worked fine for about 200 miles then turn signals quit, turn key to on and engine would start, pull in clutch and headlight would go off. Checked fuses and panic alarm would go off. Took it to dealer and he said I smoked the wiring harness and it never blew a fuse! Wonder if any else has had any experience close to this? Dealer blamed it on me. But I'm wondering if BMW has a wiring harness problem in the 03's?
TIA Gerard
 

·
Registered
Joined
·
718 Posts
You definitely should use an isolation wiring harness on the LT. This type of harness will give you extra protection (of BMW's expensive brake components) if you happen to have a short to ground in the trailer wiring. It will also allow your trailer lights to work with the BMW braking system without any issues.
 

·
Registered
Joined
·
718 Posts
The Dauntless 4 relay isolator is an excellent product IMO. If properly installed, I don't see how you could have had a problem, but I guess things happen.
 

·
Registered
Joined
·
718 Posts
I just tool a gander at the dauntless site. If you bought their single relay harness, you would have no isolation of any circuits except the brake light circuit. With the single relay harness, if you have a short to ground in the trailer wiring, the high current would run through the factory wiring harness for those circuits that are not isolated. With that said, the factory supplied circuit protection should have protected the wiring harness. Hopefully, you had the correct size fuses installed for those circuits.
 
1 - 6 of 6 Posts
Top