BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
Hit my rear brake today and nothing -no pressure on pedal
Any thoughts? Cant see any leaks anywhere.
 

·
Registered
Joined
·
2,406 Posts
ltcanup said:
Hit my rear brake today and nothing -no pressure on pedal
Any thoughts? Cant see any leaks anywhere.
No Bike BIO .... What year ?
 

·
Registered
Joined
·
3,137 Posts
ltcanup said:
Hit my rear brake today and nothing -no pressure on pedal
Any thoughts? Cant see any leaks anywhere.
Bill, you had not had the rear pads out for any reason had you? Replacing them maybe? If so, you will get nothing until the pistons push back out to where the pads are contacting the rotor. Of course it should only take a pump or two. If you're saying that you can't get any pressure that is a problem.

John
 

·
Registered
Joined
·
2,341 Posts
Symptom... no rear brake and full travel of foot petal..

Need more information. :confused:

Do you have the normal ABS light sequence at startup. i.e. turn the key on and it flashes back and forth. ??
 

·
Registered
Joined
·
161 Posts
Discussion Starter #6
Thanks guys I found the problem.Worn brake line from the adapter block to the rear caliper.It is in the only crook in the line just like the speedometer sensor wire Right above the banjo fitting.
Guys this should be one of the things you check when you do your checks.Could be dangerous.I know I went to brake pretty fast and no pedal.
 
1 - 6 of 6 Posts
Top