BMW Luxury Touring Community banner

1 - 13 of 13 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Replace Rear Brake pads oil soaked from leaking FD seal
Check Front brake pads-OK
Battery Switch so battery does not run down
2 more U.S. power outlets
Oil changed 20W-50
Change front, rear and clutch Brake fluids. New Speed Brake bleeders
Headlight switch
New Spark plugs
Purchase Clymer Manual
Change Hypoid in Tranny and FD twice
Extra Oil filters
Oil filter wrench
Replace Final drive bearings
Purchase extra 2nd set FD bearings
Replace FD Seal & spare
Check Air filter OK
Change coolant
Install Magnets to trip stoplights
Replace Throttle cable (freid)
Install Throttle rocker w/ tie wrap
Disconnecting the fuel canister
Copper gaskets on drain plugs all leaking
RTV final drive leaking
Brighter 70 watt H7 low beam bulb
Mount 2 drink holders
2 Spare Tires
Aux. lights installed under Head light
Windshield Winglets for passenger comfort
Shift Linkage Checked/greased twice
ABS not working, install wire off terminal 21 to reset
Grind 1/32" off kick stand stops so it goes over center better
Disconnect 1 spring on throttle to make easier to pull
Grease around handlebar to fairing (creaking rubber)
Replace input seal of transm (leaking)
Grease rubber fittings holding tank on to make easier to install
Lub 6 key holes
Set presets on radio for stations
Grease lubricate trunk and all locks
Replace CD packing screws & clean 6 CD's were skipping
Fixed "Reverse" wired around reverse controller (not unsafe)
Crankcase side gasket leak -fixed
Clutch slave cylinder weep hole
Replace pivot bearings
Missing Wheel bolt and Conical V spacer
Spare Oil filter O-ring
Replace Fuel filter
Adjust/check valve clearances
Replace burnt out Indicator bulbs
And it only has 26k miles! What did I miss? :confused:
 

·
Registered
Joined
·
2,916 Posts
ok

To ride it. :)
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,171 Posts
Whew! That is a hand full.


If you use a battery switch then you will lose the presets on the radio and you will have to re-set the TPS. Other than that enjoy, you've earned it.
 

·
Registered
Joined
·
2,399 Posts
The 70 watt headlight bulb MIGHT be a problem - some LT riders who switched to higher wattage bulbs (stock is 55 watts, I believe) reported some plastic deformation. Keep an eye on it.

- Bob
 

·
Registered
Joined
·
624 Posts
Did you remember to flush and fill the Blinker Fluid?

How about topping off the electrical system smoke? You can never have too much of this.
 

·
Premium Member
Joined
·
1,882 Posts
Take it from me, if you do this amount of work in one go there is a general build up of elbow grease. It will need striping down again........................
 

·
Registered
Joined
·
285 Posts
Clutch fluid to mineral oil?

Charlie,

Did you switch to mineral oil for the clutch fluid? Need picture or link for windshield winglets.
 

·
Registered
Joined
·
1,986 Posts
When you mention " RTV final drive leaking" what exactly was the problem and what steps did you take to correct it?
 

·
Registered
Joined
·
76 Posts
Discussion Starter #12
Forgot to tell you...

All of these have been since I bought it in June 07. But the last few hardest ones I'm still doing and waiting on pivot bearings.

Forgot I put in a new GW GL1100/1200 20Ah battery also. See my other post.

As for the FD leaking. Put in a new seal and crown bearing and it still leaked! Found it leaking around the housing O-ring, did not have one that big nor had enough to order more parts so I clear RTV'ed it.

For the windshield winglets to go:
http://www.vpaccessories.com/misc_.htm About $40 but is too narrow, needs to be 5" wide, mfg'ed at 3" wide. Another Project for the future!

Mineral oil for the clutch fluid? Please explain or is this a joke?

I suspect this won't be the last time the tupperware will be off. 4 times already.

BUT I really want to ride it especially if the ABS terminal 21 grounding resets it.
 
1 - 13 of 13 Posts
Top