BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #1
I filled up this evening at Safeway, using premium. Got a mile down the road and the bike began sputtering and stopping. Did that quite sometime. Anyone else ever have this issue? Right after I left I saw the tanker pull up to drop a fresh load into the tanks.
 

·
Premium Member
2011 R1200RT
Joined
·
8,158 Posts
Maybe just crud and not water. This sometimes happens when the station tanks get close to empty, and also when the tanks have just been refilled. All the garbage in the tank gets disturbed and mixed with the "good" gasoline.
SeaMarshal said:
I filled up this evening at Safeway, using premium. Got a mile down the road and the bike began sputtering and stopping. Did that quite sometime. Anyone else ever have this issue? Right after I left I saw the tanker pull up to drop a fresh load into the tanks.
 

·
Premium Member
Joined
·
7,565 Posts
It's possible you sucked up some crud from the bottom of the station's tank, and your fuel filter is clogged. A couple of questions - have you been riding in the rain lately, and have you removed the evaporative canister (the canisterectomy) from you LT? If the answers are yes and no repectively, it could be a clogged canister that you need to remove or at least disconnect. If you haven't done so get down next to the gas cap and open it with your ear next to it, If you hear a "whoosh" then it's likely your canister is clogged.
 
1 - 3 of 3 Posts
Top