BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
I hope everyone is great. Question: I just washed my bike, it was almost yellow due to pollen. When I had finished wiping her down, I was going to put her back in the garage. I turned the key, hit the switch and she turned over once and that was it, lights are on but nothing happens when I hit the switch. Have not had time to check it out yet because of an appointment, any ideas?
 

·
Registered
Joined
·
74 Posts
Hey Tony,

Sounds like what happened to me last week, turns out it was my battery. You may start there.

Brian
 

·
Registered
Joined
·
187 Posts
Discussion Starter #3
Thanks Brian, However I just got home and decided to try it once more, yep she fired right up. How weird is that. :confused:
 

·
Registered
Joined
·
1,514 Posts
the battery has a bad cell get a new one, classic symptom of battery failure
 

·
Registered
Joined
·
74 Posts
Hey Tony,

Glad she started up for you, but if I were you I'd carry me some jumper cables in case it doesn't start while out and about.
 

·
Registered
Joined
·
256 Posts
quickbeemer said:
...she turned over once and that was it, lights are on but nothing happens when I hit the switch.
That does not sound like a dead battery or a dead cell, unless the lights were on but visibly dimmer. It could be a "bad spot" on the starter commutator, or some moisture related problem that went away after it dried, etc.

Don't be in too much of a a hurry to replace the battery, have it tested first.
 
1 - 6 of 6 Posts
Top