BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Help..... Going to the national rally on Wednesday. Prepping the bike (Tank) for the journey and discovered that my right turn signal indicator light and the front and rear lamp are illuminated and I cannot get it to cancel ! Switch gone bad? Only the right indicator affected. I can activate the signal and the light blinks faintly which makes me think it could be the ground? However wha is causing the light to remain on?

Most appreciated,
Anthony
 

·
Premium Member
Joined
·
4,886 Posts
Did you check the bulbs to confirm both filaments in each are good? I would be surprised if it turn out to be the flasher if the left side works fine.

What about when you engage the four-way flasher? Left and right bulbs flash at same brightness? Easy way to see if all filaments intact and working.
 

·
Premium Member
Joined
·
1,595 Posts
tdkmark said:
Help..... Going to the national rally on Wednesday. Prepping the bike (Tank) for the journey and discovered that my right turn signal indicator light and the front and rear lamp are illuminated and I cannot get it to cancel ! Switch gone bad? Only the right indicator affected. I can activate the signal and the light blinks faintly which makes me think it could be the ground? However wha is causing the light to remain on?

Most appreciated,
Anthony
You are on the right path, it is most likely a ground issue (brown wires), look to see a bad or loose connection. Sometimes a fuse that has corrosion on it will also present in this way.

The faintly glowing light is a common indicator of an open ground. Another common one is when you use a turn signal they all blink but not brightly, although you usually will see this on a trailer with a bad ground, it can happen on any vehicle.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
13,919 Posts
The bulbs in the rear assy have a common ground with all the other bulbs back there so I would look there first. Pull all the bulbs back there except the turn indicator bulbs and plug it back in and see if that changes anything. Then put them back and try pulling both the front and rear bulbs for the turn signals on that side and see if the dash indicator is still on. If so then I suspect the flasher unit has gone south.
 
1 - 5 of 5 Posts
Top