BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
Last night the HI-Beam HID headlight quit working. I inspected the wiring and connections and looked at the bulb, no obvious problems. So how do I go about checking out the ballast, igniter, and bulb? What does a blown bulb look like? I feel unarmed running around with no HI-Beam. Kinda like having no horn!
 

·
Registered
Joined
·
528 Posts
Rusty, first thing I would do is make sure you still have a good ground for the high beam. Then, I asume you have an HID low beam also, just plug the low beam ballast into the high beam, if the bulb lights then your high beam ballast is bad, if not you have a bad bulb.

Good Luck
 

·
Registered
Joined
·
143 Posts
Discussion Starter #4
patroa1 said:
Rusty, first thing I would do is make sure you still have a good ground for the high beam. Then, I asume you have an HID low beam also, just plug the low beam ballast into the high beam, if the bulb lights then your high beam ballast is bad, if not you have a bad bulb.

Good Luck
Did exactly what you said, sure enough, Hi-Beam fuse blown. My kit came with replacement fuses. But they're 10 AMP not the original 7.5 AMP.... I'm hunting around for 7.5 AMP don't like to lose what protection I have. I even know why it blew. Corrosion on the negative battery terminal wasn't allowing the battery to keep a full charge. and I had to jump start it once. Hi-beam fuse must have blown during the jump.

Thanks again,
 
1 - 4 of 4 Posts
Top