BMW Luxury Touring Community banner
1 - 9 of 9 Posts

·
Registered
99 K1200LT
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, new member here and very new to BMW motorcycles. Short story is I have a 1999 K1200LT that recently had the throttle cables replaced, and in looking over what sins were committed in removed and reassembling everything, I noticed there was a single-wire connector with a knurled aluminum or galvanized threaded body.

I have absolutely no idea what this is, but it sort of looks like the center tip is busted.

Additionally, the bike ran fun before the cable swap, now, If I twist the throttle very quickly from idle, she stumbles all over herself and dies. If I give it throttle very slowly, it's okay.

Very much appreciate the help here!

Cheers,
Bob
 

Attachments

·
Registered
2003 BMW K1200 LT (88K on 2020/08/13)
Joined
·
205 Posts
While not an expert, it appears to be comms related, like a CB or FM anttena connection. It appears in picture #1 that it leads up toward the stringray.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,427 Posts
That is a standard RF connector (PL-259 with RG-58 cable) for user added CB or Ham radio. Just tuck it away where it won't get caught in anything.
 

·
Registered
Joined
·
715 Posts
Additionally, the bike ran fun before the cable swap, now, If I twist the throttle very quickly from idle, she stumbles all over herself and dies. If I give it throttle very slowly, it's okay.
@jzeiler , is this a symptom of the throttle position sensor needing calibration?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,427 Posts
@jzeiler , is this a symptom of the throttle position sensor needing calibration?
Not necessarily. The TPS reset (key on , no start, open and close throttle x2, then key off) may help but the bike re-learns this information with in a few rides anyway. I would check that there is sufficient play in the throttle cables.
 

·
Registered
2009 R1200RT, 2003 K1200LT Hannigan Conversion Trike
Joined
·
111 Posts
Hello all, new member here and very new to BMW motorcycles. Short story is I have a 1999 K1200LT that recently had the throttle cables replaced, and in looking over what sins were committed in removed and reassembling everything, I noticed there was a single-wire connector with a knurled aluminum or galvanized threaded body.

I have absolutely no idea what this is, but it sort of looks like the center tip is busted.

Additionally, the bike ran fun before the cable swap, now, If I twist the throttle very quickly from idle, she stumbles all over herself and dies. If I give it throttle very slowly, it's okay.

Very much appreciate the help here!

Cheers,
Bob
I bought a 2003 with a CB Radio installed, and that was the identical cable and location when I disconnected the radio.
 

·
Registered
Joined
·
4,585 Posts
My thoughts are that you popped off one or more of the 4 rubber hoses connecting the purge valve to the throttle body. Check those to make sure they are all still on.

Motor vehicle Vehicle Automotive exterior Electrical wiring Gas
 
  • Like
Reactions: kbob12 and djmellor
1 - 9 of 9 Posts
Top