BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
699 Posts
Discussion Starter #1
Any words of wisdom on adjusting throttle cables. Over the Holidays I replaced my old cables with the newest cables and the repair kit on the right grip but I can't quite get the adjustment right. The opener cable by it's self seems to work fine but the closing cable is giving me fits. When I attach the closing cable the throttle binds up and won't return to the original position when released. If I try to adjust the length with the adjuster at the end the binding gets worse. I've routed the new cables along the same path as the original cables keeping the opening cable (green mark) to the outside of the run and I've added the hole in the right lower handlebar cover as per other comments on this site. I've attached the cables in the same location to the frame bracket as the old ones. And yes, the cruise won't engage but I wouldn't expect it to until the cables are properly adjusted. After working with it for a couple of days I don't seem to be making any progress. Any suggestions?
 

·
Registered
Joined
·
115 Posts
McAllister said:
Any words of wisdom on adjusting throttle cables. Over the Holidays I replaced my old cables with the newest cables and the repair kit on the right grip but I can't quite get the adjustment right. The opener cable by it's self seems to work fine but the closing cable is giving me fits. When I attach the closing cable the throttle binds up and won't return to the original position when released. If I try to adjust the length with the adjuster at the end the binding gets worse. I've routed the new cables along the same path as the original cables keeping the opening cable (green mark) to the outside of the run and I've added the hole in the right lower handlebar cover as per other comments on this site. I've attached the cables in the same location to the frame bracket as the old ones. And yes, the cruise won't engage but I wouldn't expect it to until the cables are properly adjusted. After working with it for a couple of days I don't seem to be making any progress. Any suggestions?
Can you post a picture of the hole the new cable's go through? I found this can be a factor. Try loosening the lower handlebar cover allowing you to remove all stress from the cables. If this helps, placement of the hole is to close to grip end. and the hole needs to be expanded. You may find un-hooking the return cable from the fan bracket helps free movement. Lastly you may need to reroute the cables, I did with improved results.
Good Luck,, Pete AKA Murray
 

·
Registered
Joined
·
103 Posts
It sounds like you have the cables adjusted a little too tight working
against each other. Try first adjusting for the cruise cancel switch
so when you roll the throttle back you can hear the micro switch make
then when you release it you can hear the
switch click again releasing.

Then adjust the throttle cable till you can feel a little free play when rocking
the grip back and forth and you should be good to lock them down.
 
1 - 4 of 4 Posts
Top