BMW Luxury Touring Community banner
381 - 395 of 395 Posts

·
Registered
Joined
·
155 Posts
Strange how many other commentators e.g. on Facebook say that it's Android phones that work best with the TFT and that iPhone users have the most problems :oops:

Personally I can't see why anyone would want to listen to music while riding a motorcycle - I need all of what's left of my wit and senses to try and keep aware of all the nutters who are out to kill me on the road.
 

·
Registered
Joined
·
132 Posts
I tried for about a week after getting the bike to use my iPhone (just for nav) and had constant problems with wifi disconnects and app crashes. Dug out an old Motorola running Android 9 and it just works. It’s not even a wireless charging model - I just bought a right angle USB cable and plugged it in. No disconnects, no crashes and it (Hallelujah!!) reconnects itself after I stop the bike.
Not interested in music / phone calls so I’m happy for now.
 

·
Registered
Joined
·
135 Posts
Personally I can't see why anyone would want to listen to music while riding a motorcycle
And I get that - motorcycling is just out there being one with the world. All about the freedom and why would you want to have music ?

But also, find some nice roads. Hit dynamic mode, find some good tunes (for me, classic rock) and you’re in another world.
 

·
Registered
Joined
·
135 Posts
I tried for about a week after getting the bike to use my iPhone
Have to say, I really don’t know what’s going on, nothing has been updated, nothing has changed, but all of a sudden, my iPhone paired to the 21RT seems to be behaving itself. Yes, I have to wait what feels like an eternity for everything to connect, but sure enough, it connects - and it works. Witchcraft.
 

·
Registered
Joined
·
135 Posts
Seems Apple music works well.
Right, I don’t know if you have jinxed my set up - I have now found the exact same issues with Apple Music, pausing after playing a track. Its seems not to be an Amazon Music issue but a BMW TFT issue !!

What I have found is that if you start playing music from the TFT - I selected All Tracks, Shuffle mode, pressed play, it seems to work fine. However, if you stop the bike and turn off the ignition, when you restart, if you press button 1 (or press play from the media screen) to resume the music, it will only play one track at a time. You have to press button 1 again to move onto the next track. But, if you go back to the media menu and select all tracks again (or whatever you want) it will now play one track after another as it should. Seems like you have to reload the track list if you re-start the bike for it to work properly.
 

·
Registered
Joined
·
155 Posts
Well that comment of his is queried in the comments and he insists that they are assignable.....(but then he does wear those gloves......)
 

·
Registered
Joined
·
132 Posts
Hey guys, this is a bit embarrassing but I seem to have managed to lose turn by turn directions but not media playback. I’ve been messing around trying to get both directions from the Android ‘bike phone’ and alerts from my BT transmitter attached to my Uniden R7 radar detector at the same time.
Turns out that’s mission impossible - First I had just directions, then I re-paired everything and had just RD alerts. Now I have left the BT transmitter off, I can hear media being played from the bike phone but not route guidance…
I’ve checked guidance hasn’t been accidentally switched off on the phone or bike so I’m at a loss. How can media play (that I’m not bothered about) but route guidance not?
Just wondering if there’s anything obvious I could’ve done / not done.
 

·
Registered
Joined
·
321 Posts
Discussion Starter · #393 · (Edited)
@GeordieTraveller Ok, lets get complicated. When you checked route guidance were you on the bike following a route or, were you at home and plotted a route to say a petrol station using the POI on the bike?

If you were mobile and following a route you should get guidance (provided the App and TFT settings are switched on).

If you were at home and pressed the "Repeat Instruction" on the map, you may not get guidance and the reason for this is that is BMW have it switched off until you are moving, honest, its in the email they sent to me and I demonstrated it in the video I did.
 

·
Registered
Joined
·
132 Posts
@GeordieTraveller Ok, lets get complicated. When you checked route guidance were you on the bike following a route or, were you at home and plotted a route to say a petrol station using the POI on the bike?

If you were mobile and following a route you should get guidance (provided the App and TFT settings are switched on).

If you were at home and pressed the "Repeat Instruction" on the map, you may not get guidance and the reason for this is that is BMW have it switched off until you are moving, honest, its in the lemail they sent to me and I demonstrated it in the video I did.
Cheers David I think you hit the nail on the head. I said it was embarrassing - I must’ve watched your video 2 or 3 times and closed it as soon as the talking stopped. Lol. Of course now I see what you mean. That would explain the “intermittent” problem! I’ll give it a shot this morning.
 

·
Registered
Joined
·
132 Posts
@GeordieTraveller both the app and the TFT have separate settings for audible guidance. Did you check all of those?
Yeah, like I said in my post .
Thanks for the suggestion. Looks like David has identified the problem. I’ve been pairing, re - pairing, factory resetting and pairing to different channels so much I think I ended up confusing myself! . I sure know how my Cardo Packtalk works a lot better now than I did before I got this bike!
 
381 - 395 of 395 Posts
Top