BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
I’ve read before about this problem of mine, but couldn’t find it in the search so let’s do it again.

A long while back I put a CD in my “single” CD player and had trouble getting it to play or eject, but it did after a while. Like a dope, the other day I put one in again and when I pushed the CD button the display said NO CD as I continued to push the button it cycled through all the options. Went to FM and then back to CD and again NO CD. I read the manual and I was doing everything right, but with no results. Later that night I push the CD button again to see what would happen and it played. Oh boy its fixed. Pushed the eject button and it came out, I put it back in and it played, ejected it again. WOW it must be fixed. Not so quick, Grasshopper. I put it in again and nothing. Damn. (Will I ever learn?) No play, no eject. But this time the display just says TR so now it knows a CD is in, but it can’t find a track.

Its in there and I can’t get it out….. What do I do???
 

·
Registered
Joined
·
3,525 Posts
Mechanism

Sounds like something in the mechanism is binding. Probably needs lube...

I suggest you flood the unit with 10W40 and let it set for 8-10 hours. :D

Just kidding,

Probably the thing to do is to power off the radio and power it back on a few times. Maybe it'll either park itself properly and work again or eject.. Either way sounds like the mechanism needs to be lubed or maybe a microswitch is failing or loose, could be any of a half dozen different things.

Just keep powering it off and back on and I bet it'll at least get you out of trouble till the next time you insert a cd.....Or pull the unit and take it to the repair shop..

Good Luck

John
 

·
Old Slow Guy in A Fast Car
Joined
·
8,601 Posts
Had the same trouble with my CD player.My easy fix was Sirius satalite radio it works great
 

·
Registered
Joined
·
78 Posts
Discussion Starter #4
GOOD NEWS…. I got it to eject. What did I do? I washed the bike. Well there’s more to it than that. While drying the bike I turned on the radio for some tunes, and of course I tried the CD and nothing as usual. After finishing the bike I climbed on to drive it back into the garage. With the radio still playing, I turned the ignition key, waited for the lights on the dash to do what they do, and pushed the start button. As you know when you start the bike, the head light goes out and it appears the radio goes off momentarily as well. It came back on and I road into the garage, turned off the bike but before turning off the radio, I pushed the eject button one more time and out it came. The next thing that crossed my mind was,,,,, should I put it back in? NO WAY . . . It’s time to quit while I’m ahead.

So did starting the bike while the radio was on give it a quick reboot? Was it because I just cleaned the bike and that it was rewarding me for making it feel good? What?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #6
No longer under warranty :( I didn't get the extended warranty at the time of sale and had a year to decide if I wanted it, the next thing I new, I had 36,000 miles on the bike and the year was up. Oh well. But the bike has been good for me, the only major thing I've needed to replace has been the rear brake rotor.
 
1 - 6 of 6 Posts
Top