BMW Luxury Touring Community banner
781 - 800 of 866 Posts

·
Registered
Joined
·
169 Posts
His trouble started well after the TFT update, and if his phone wasn't paired, then he wouldn't have gotten the turn-by-turn instructions at all! You need to look back several posts to see where this all started.
All was working perfectly before the 3.2.1 app update and I had ridden 600 miles over the 2 days before the update. It was flawless. Then after the update I get no maps so something changed, maybe a setting that I'm missing. If you have 2 Pixels running without issues on 3.2.1 then I'm going to try to uninstall-reinstall the app to see if that works. I have tried my old iPhone SE and it does show maps but it's a PIA after stops and does crash sometimes while riding so that's not a good option for me.
 

·
Premium Member
Joined
·
5,839 Posts
All was working perfectly before the 3.2.1 app update and I had ridden 600 miles over the 2 days before the update. It was flawless. Then after the update I get no maps so something changed, maybe a setting that I'm missing. If you have 2 Pixels running without issues on 3.2.1 then I'm going to try to uninstall-reinstall the app to see if that works. I have tried my old iPhone SE and it does show maps but it's a PIA after stops and does crash sometimes while riding so that's not a good option for me.
Yeah, I have tried all of that before too and no luck! That's why I bit the bullet and did go in to get the update. Like you, I had almost 4,000 miles of perfect Nav performance until 3.2.1, and the RT's software update fixed it for me. So, the only variable left is the integrity of your TFT software update!
 
  • Like
Reactions: RupertB

·
Registered
Joined
·
51 Posts
good luck David.
The update is working well for me ref maps.
Media is better, but not quite there. Once I had to unlock my phone in its cubby hole, and now I have stopped Huawei music accepting bluetooth commands (Who knew that was important?) my Media monkey fires up a minuite or so after I fire up the bike. No instant, but hitting Favourite button 3 (programmed to mute music or actually pause/unpause) it does seem to eventually play.

no playlists to chose from, or album art. But that peripheral.
 

·
Registered
2021 R1250RT
Joined
·
34 Posts
Did you check to see if your phone is still paired? I had to re-pair my phone after the TFT update as it disappeared. But as I've said before the TFT works as it should, I don't use voice commands as I find it easy enough to just glance at the map. I'm pretty good at knowing when a particular distance has pasted as I'm riding, so if it shows next turn is 10 miles away there's no need to look for about 10 minutes. Only time the map disappears is when I get a weather warning from another app but that's momentary as it's the banner that pops up that does it, and that lasts about 5 secs, then the map returns and everything is back to normal. I made the suggestion to the connected app people to look at how the SXM app works because once you start that app you can shut the screen off and app still keeps going till you manually close the app. Unlike the connected app which once it loses the on top position it stops working..............................
I went to the dealer for the software update and other service and when I got the bike back after four hours I was ready to shoot out of there. The only problem was my TFT was blank on navigation and media screens. I had to re-pair my phone and helmet to the TFT. I wasn’t familiar with the procedure as when I bought the bike the dealer had set it all up. The wifi still drops my maps occasionally. I worry about using navigation through busy traffic as I never know when it will disappear. Maybe it will work better.
 

·
Registered
Joined
·
169 Posts
I have tried everything and can't get the phone to connect via Wi-Fi to display the maps since 3.2.1. I'm getting a Pixel 6 when released later this month so hopefully that will fix my problem. And I was one of the happy ones before the update.

I don't have a list of what was changed with the TFT update but it was multiple pages with multiple updates - not just to the TFT.
 

·
Registered
Joined
·
169 Posts
Yeah, I have tried all of that before too and no luck! That's why I bit the bullet and did go in to get the update. Like you, I had almost 4,000 miles of perfect Nav performance until 3.2.1, and the RT's software update fixed it for me. So, the only variable left is the integrity of your TFT software update!
Here is my theory - right or wrong. You were on the prior TFT version and installed 3.2.1 which broke the Wi-Fi connection to the bike. I am on the current TFT version (12.7.30) and installed 3.2.1 which broke the Wi-Fi connection to the bike. I think my TFT update was successful, but it must reset something that I am not able to do. BMW's suggestion was to do a TFT reset (Settings -> Reset All) which I have done but still no Wi-Fi connection.

So, what does that all mean? I don't know. I am going by my dealer today to talk to them about it.
 
  • Like
Reactions: PadG

·
Premium Member
Joined
·
5,839 Posts
good luck David.
The update is working well for me ref maps.
Media is better, but not quite there. Once I had to unlock my phone in its cubby hole, and now I have stopped Huawei music accepting bluetooth commands (Who knew that was important?) my Media monkey fires up a minuite or so after I fire up the bike. No instant, but hitting Favourite button 3 (programmed to mute music or actually pause/unpause) it does seem to eventually play.

no playlists to chose from, or album art. But that peripheral.
Media Monkey works well? As I mentioned, using YouTube Music, in order for the system to recognize any media at all was to have the first track of my per-selected list (or Playlist) actually playing! That's the little annoying part. If using Media Monkey will allow media recognition just by having the app active, then I will give that a try!
 

·
Premium Member
Joined
·
5,839 Posts
I have tried everything and can't get the phone to connect via Wi-Fi to display the maps since 3.2.1. I'm getting a Pixel 6 when released later this month so hopefully that will fix my problem. And I was one of the happy ones before the update.

I don't have a list of what was changed with the TFT update but it was multiple pages with multiple updates - not just to the TFT.
I still say it's the bike's update! No, it's not just updating the TFT, which was why I had been avoiding that term in the past, and only use it this once to conform! I doubt that Pixel 6 will be your solution, considering that everything works fine with the original Pixel (with ancient version of Android) as well as my present Pixel 4a-5G running the same Android as your Pixel 3!

Go and talk to your dealer and present these facts!
 

·
Registered
Joined
·
51 Posts
Media Monkey works well? As I mentioned, using YouTube Music, in order for the system to recognize any media at all was to have the first track of my per-selected list (or Playlist) actually playing! That's the little annoying part. If using Media Monkey will allow media recognition just by having the app active, then I will give that a try!
Yup, its now worked a few consecutive times. I not only have to have MM as the default music player, but as I said, stop the generic music player take messages from bluetooth. (In my case Huawei music (HM)) . I rationalise that by assuming the message being sent to play from the TFT was being picked up by a player I never used so it never played anything. I only thought of it as a possibility, when digging about the settings, I found the Huawei player, played it a bit, decided I did not like it, then the next time I was on the bike, the bike kicked HM into play. I changed a few settings, and MM now plays the latest playlist I had running.


A bit garbled, but hope it help you decipher.
 

·
Registered
Joined
·
169 Posts
I still say it's the bike's update! No, it's not just updating the TFT, which was why I had been avoiding that term in the past, and only use it this once to conform! I doubt that Pixel 6 will be your solution, considering that everything works fine with the original Pixel (with ancient version of Android) as well as my present Pixel 4a-5G running the same Android as your Pixel 3!

Go and talk to your dealer and present these facts!
Spent a couple of hours at the dealer this morning. The BMW Tech hooked it up to check for updates and all were up to date. The demo truck was there today so it was quite busy, so I was happy he spent so much time with me and checking everything. The funny thing is that he connected his phone (Samsung Galaxy S10) and like me he only saw turn-by-turn arrows. After checking that his version was 3.2, he updated to 3.2.1 and after that it wouldn't connect at all. Not sure what's going on but I'll be waiting for an Android app update and the RT update in November or December. I'm still confused.
 

·
Registered
Joined
·
166 Posts
Spent a couple of hours at the dealer this morning. The BMW Tech hooked it up to check for updates and all were up to date. The demo truck was there today so it was quite busy, so I was happy he spent so much time with me and checking everything. The funny thing is that he connected his phone (Samsung Galaxy S10) and like me he only saw turn-by-turn arrows. After checking that his version was 3.2, he updated to 3.2.1 and after that it wouldn't connect at all. Not sure what's going on but I'll be waiting for an Android app update and the RT update in November or December. I'm still confused.
It does seem that your bike is the one constant here. When I heard that some were having problems with the Android update I delayed doing it but eventually after a lack of general outcry from other Android users I bit the bullet yesterday and it connected both Bluetooth and wifi right away. My bike is also updated to the latest software.
Can your dealer run an update again? Seems like if the system see the most recent update it won’t even try but I wonder if it could be forced?
 

·
Registered
Joined
·
169 Posts
Can your dealer run an update again? Seems like if the system see the most recent update it won’t even try but I wonder if it could be forced?
I asked about that but was told it's not possible to force an already applied update.
 

·
Premium Member
Joined
·
23 Posts
How Not to be The Dumbest Looking Guy in the Parking Lot...

Finally, yesterday, I retrieved my 2021 R1250RT after it had received its software "update." Said update took approximately three (3) hours to complete.

For those of you playing along at home, the dealer needs to update their diagnostic computer to ISTA version 4.31.16. Then, they connect your bike to their computer and install the most current I-Level software onto your bike -- version 21.07.520 as of this writing. When it is all complete the software version that will be displayed on your bike (Settings Menu, Software Versions sub-menu) will be 012.007.030. All of this was done.

Turn on the bike, watch it go through its power-on self test routine, launch the BMW Motorrad Connected app (most current version = 3.2.1 (build 321003) ). No connection. Nothing. No joy. Crickets.

I try again. And again. Restart the phone. Delete and re-install the app (but you will need to re-install any maps you need if you do this, so best to be connected to the dealer's wifi network!). And a whole bunch of other panic/anger/frustration based "fixes" that could have worked. Beginning to wonder why I even had bothered to get the update... nothing was working, no connection at all between the iPhone 11 Pro Max and the RT.

So let's cut to the chase...

A calmer and obviously better experienced technician asks, "Did you disconnect all previous devices from your setup, then re-connect everything?" A-HA!! Did not do that!

• From your phone, disconnect the bike from your Bluetooth devices list.
• From the Connections menu on the bike, disconnect your phone. And disconnect helmet/comms if they are even still showing.
• I shut down and restarted my phone -- possibly did not need to do this, but I figured it could only help "just in case."
• Next, re-paired my phone to the bike. Re-paired my helmet/comms to the bike.
• Launched Motorrad Connected app… held my breath… asked a passing cloud for help… and…

Success! Finally the app connected to the bike. After about a 40 second wait (typical, “normal”) Maps Mode linked up to the TFT. It appears to be working.

Therein lays my tale of how I snatched victory from the jaws of despair, which would not have happened without the very professional and patient service managers and technicians at MAX BMW!

It Ain’t Over ’Til It’s Over…

Some of the problems I had been experiencing are now fixed. Many of the concerns I have voiced to Motorrad Connected are NOT fixed…yet.

In the Media arena, songs will now play “seamlessly”, one after the other. This fixes the old problem of having only one song play through, then the system stopping playback. There is still no access to one’s song library or playlists via the TFT and handlebar controls. This may be a iPhone related problem, but it is still irritating and flawed. Grrrrr…

In the Phone arena, the phone functions work. I can access my contacts list, make calls and receive calls. No change here as this function worked previously.

In the Navigation arena, the Connected Maps Mode may be working somewhat better… too soon to tell, really. The maps appeared as they are supposed to, the GPS tracking was functional, and the map stayed visible and active without disconnecting after five minutes as it used to… right up to the moment I activated a New Destination from my stored destinations list — which promptly disconnected Maps Mode from the display, throwing me into white arrow only display mode with no turn-by-turn information at all. Grrrrr… Obviously I need to do a lot more testing.

Other Things…

This software update makes some other changes “under the hood.” I have no documentation of these proported changes. For example, I am pretty darn sure there has been a modification to the control instructions governing the suspension dampening settings when in ROAD mode, eliminating some of the fore-to-aft pitching I had been experiencing in that mode only. Might just be me but I am pretty sure others have noticed this effect?

I wish BMW would confirm ALL of the changes that are made with any subsequent software update, but I am not holding my breath for that to happen. This will be tantamount to BMW admitting they shipped a flawed (and in some regards a potentially unsafe) vehicle to their new beta testers buyers. But I can hope?

Anyway, I think some things will be “better” under the new software, and some issues will remain to be fixed. This really sucks for us owners, and it also sucks for the dealers who have to give up their diagnostic computer for three hours at a stretch when performing the bloody updates! My 2¢ worth.
 

·
Registered
Joined
·
242 Posts
Just to keep a broader perspective on things - I read in Bike Magazine that the Ducati Multistrada phone navigation system doesn't perform as it should... :rolleyes:

I have just bought a Zontes ZT310 -T as a second bike for pootling around - the TFT on this bike makes two Bluetooth connections (yes 2) to my phone and is supposed to show turn by turn navigation on the screen - but it doesn't do anything at all. A comment on FB group says this is because Zontes don't have a Google maps licence for Europe....

I shall be fitting a mount for my Zumo XT to that one as well as the RT 🤣
 

·
Premium Member
Joined
·
5,839 Posts
Yup, its now worked a few consecutive times. I not only have to have MM as the default music player, but as I said, stop the generic music player take messages from bluetooth. (In my case Huawei music (HM)) . I rationalise that by assuming the message being sent to play from the TFT was being picked up by a player I never used so it never played anything. I only thought of it as a possibility, when digging about the settings, I found the Huawei player, played it a bit, decided I did not like it, then the next time I was on the bike, the bike kicked HM into play. I changed a few settings, and MM now plays the latest playlist I had running.


A bit garbled, but hope it help you decipher.
I installed MediaMonkey, and yes it is a very nice app, BUT for me, the connectivity features are exactly the same as YouTube Music! No difference at all!!!! OTOH, I do like MM a lot. It has more features than YouTube Music, with respect to stored music files, and (so far) it doesn't continuously try to get me to go for the "premium" pay services that YouTube does!! :)
 

·
Premium Member
Joined
·
5,839 Posts
It does seem that your bike is the one constant here. When I heard that some were having problems with the Android update I delayed doing it but eventually after a lack of general outcry from other Android users I bit the bullet yesterday and it connected both Bluetooth and wifi right away. My bike is also updated to the latest software.
Can your dealer run an update again? Seems like if the system see the most recent update it won’t even try but I wonder if it could be forced?
I think that is what I would insist that the dealer do - re-run the update! It is very clear to me that the bike is the only variable that is causing David's problem.
 

·
Premium Member
Joined
·
5,839 Posts
I asked about that but was told it's not possible to force an already applied update.
Possibly because they wouldn't get paid the second time? The time spent to do the updating is paid by BMW, since it is a warranty issue!
 

·
Registered
Joined
·
52 Posts
Spent a couple of hours at the dealer this morning. The BMW Tech hooked it up to check for updates and all were up to date. The demo truck was there today so it was quite busy, so I was happy he spent so much time with me and checking everything. The funny thing is that he connected his phone (Samsung Galaxy S10) and like me he only saw turn-by-turn arrows. After checking that his version was 3.2, he updated to 3.2.1 and after that it wouldn't connect at all. Not sure what's going on but I'll be waiting for an Android app update and the RT update in November or December. I'm still confused.
Have you tried a complete restart (turn off, wait, turn on) of the phone? In rare cases where I couldn't connect a phone restart made it work. If that doesn't work, try to get someone with an iPhone and see if you can connect with one. If it works with iPhone, then the issue is not on your bike/TFT.
 

·
Registered
Joined
·
169 Posts
Have you tried a complete restart (turn off, wait, turn on) of the phone? In rare cases where I couldn't connect a phone restart made it work. If that doesn't work, try to get someone with an iPhone and see if you can connect with one. If it works with iPhone, then the issue is not on your bike/TFT.
Yes, I've tried everything. Like I said before, my old iPhone SE does work and shows maps but has its own issues with restarts and crashes when I try to zoom or enter a new destination.

PadG - the difference between you and me is that I installed 3.2.1 after the RT update and I think you did it before - not that that should make a difference. I also think you are right in that the Pixel 6 probably will not fix my problem. I'm thinking that an Android app update or the November/December RT update will. Right now I'm just enjoying the new RT and trying not to focus on the map issues.
 
781 - 800 of 866 Posts
Top