BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
It continues to amaze me the amount of serious information that exists here. My speedometer was intermittent for awhile, then finally died. On a related note, my cruise control was acting up at the same time. (Duh!)

Today I did a quick search, found an entry by Dave Shealey saying with certainty that if the bike was 2002 or older, it was a broken speedo cable tied to the brake line. I pulled the plastic off (which was the hardest part) and sure enough there was the culprit. Actually the culprit was the guy that had this bike before me and did a crummy job fixing it the first time. I soldering in some new wires, bolted everything back together and everything works.

Thank all of you that contribute so much. I'd either be a lot poorer having to take it to the shop each time or it would be sitting in the garage instead of crusing the highways.

Thanks again!
 

·
Registered
Joined
·
2,746 Posts
Nicely done! You can get by without the speedometer but not without the cruise control. At least that was my experience.

Loren
 

·
Registered
Joined
·
4 Posts
A big thank you from over here as well. My speedo just kept bouncing like a basketball, and I was like..NOOOOOO, not my baby!!!

That is what brought me as a new member to this forum.

However....

My first search on the speedometer issue...I got hit with posts that this is often a precursor to final drive failure :confused: :mad: :( I went through all kinds of emotions over that...lol.

Then, I finally landed on an old thread with Dave's input about that notorious zip-tied-to-brake-line wire damage. 45 minutes later...with soldering and two layers of shrink tube, the second having that gooey sealing property to keep out the water, and I was singing the praises of people like Dave and forums like this.

Is there any way to create a STICKY for such a common problem as this :wave
 
1 - 3 of 3 Posts
Top