BMW Luxury Touring Community banner
1 - 7 of 7 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter · #1 ·
I parked my bike on Thursday evening. Everything was perfect. On Monday morning when I try to start the bike the battery was low and it wouldn't start. I left it on tickle charger for a couple of hours on Monday evening and it started just fine. Today (Tuesday) morning when I started riding it, the speedometer is behaving weird. It fluctuates +/-20mph than the actual speed I am riding at. Its stable at 80mph and then again fluctuates above 85mph.

1. Is speedometer a mechanical or an electric device? What can I check to fix it?
2. Is low battery related to the speedometer issue?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,070 Posts
It is electrical and yes it very well could be low battery related. But having said that it is far more common to get an ABS fault with a low battery than speeedo errors. My old Saturn sport coupe's dash would go crazy when the battery was very weak, dials would be all over the place and lights would flash just before she died. I sort of long for the old days when a little bit of lube would fix any cable problem on a speedo.

Best way to tell if the battery is weak is have it load tested - most auto parts stores can do it.
 

·
Registered
Joined
·
5,857 Posts
Check the speedo cable (it's electric) from the rear drive to under the passenger seat. The line tends to get a small break around one of the zip ties on the rear sub frame. It can be fixed or replaced.
You may find the the cruise control will not stay set when the speedo is fluctuating.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,070 Posts
+1 on John's note. Follow the wire from the sending unit (top of the drive) up to the cable tie along the brake line. If you have a broken wire it will be there.
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #5 ·
The cruise control did not stay on. I had cleaned the speed sensor a month ago. I hope I didn't break something. I will be checking the cable today evening.
 

·
Registered
Joined
·
43 Posts
I had the same problem on my 2001 LT (bouncing speedo needle and cruise wouldn't stay set) and it was a broken speedo wire as mentioned above.

This thread has my steps to solve it with pics

http://www.bmwlt.com/forums/showthread.php?t=46329

I posted a video of what the speedo was doing on youtube. It can found by searching for "BMW bouncing speedo"
 

·
Registered
Joined
·
253 Posts
Discussion Starter · #7 ·
Confirmation - This is the issue. I am yet to fix it, but wanted to update the thread stating how awesome everyone here is.

I am still amazed why low battery and this broken connection issue were coincident.
 
1 - 7 of 7 Posts
Top