BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Having discovered that a fully loaded (wife and bags that is) LT and the grass in tiny French lanes are not compatible I have acquired an intriguing fault! Guess the old radio doesn't like being dropped!!

When all is turned off the speakers sound as tho they are picking up a station but weakly and with bad reception (not surprisingly)....also the radio/cd now do not work via the normal switch now but even pulling the No 8 fuse does not stop the speakers...there must be a short somewhere...any ideas or am I grasping at straw!?

Thanks

Ps I know they were not designed for grassy country lanes.....lesson well learned!
 

·
Registered
Joined
·
2,423 Posts
Recently ran my battery down while messing with the GPS (headlite was also on).

Did a short charge with the"Batterytender" (5 minutes) and she started up.

Radio worked but had a mind of its own (volumn and stations changing at random).

Disconnected the battery (negative first) for about 1/2 hour (maybe a few minutes is all thats necessary?)

Now works like new.

Hope yours heals as easily.

Also check all your switches in the tank glovebox to make certain they are in the proper positions (something could have bumped them in the fall)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
Thanks Doug

Will try the battery trick tho I suspect that it will not be so simple....does it not mess up the computer settings/software..whatever?

Must admit to the train of events being set in motion by two French guys in a van shooting up the lane like maniacs so I do not feel too bad!

Will report back on the healing...
 
1 - 3 of 3 Posts
Top