BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi

I have recently purchased a 2003 LT after riding a GS for the past 3 years, i have to say it the best bike i have owned apart from people saying i look like judge Dred on it.

i have a problem that you hope fully can help me with, when i play the radio or cd the sound only comes out of 1 front speaker, i have checked the speakers individually and they all woork fine, but when i wire them back as normal only sound from 1.

is this a radio problem or could it be a loom issue.

any helpand advice would be appreciated guys

thanks :bmw:
 

·
Registered
Joined
·
676 Posts
So you are saying that sound only comes out of 1 of the 4 speakers? Do you have an intercom? does the sound only come out of 1 side of the headsets? :confused:
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
13,940 Posts
It is most likely the amp chips on the main radio board. They are ball grid array and no one will replace them. Only solution is a new board from Becker if they still have them. Many have gone to a Jensen boat replacement radio as it is much cheaper than the repair.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
casualemt said:
So you are saying that sound only comes out of 1 of the 4 speakers? Do you have an intercom? does the sound only come out of 1 side of the headsets? :confused:
Hi yes sound only comes out of 1 front speaker, and yes the bike has an autocom system but havnt tested it yet as i dont have the headsets getting them the weekend, could this be the cause?
 

·
Registered
Joined
·
6 Posts
Just had the same problem. Had to remove the radio unit and ship it to Becker Autosound. They are easier to reach by email [email protected].
It took 1 1/2 weeks from the time I removed the radio shipped it and got it back in my hands. If you want a new radio the best price is at BMW Chicago $652.00. Phone is 773-274-6820. Good luck.
 
1 - 5 of 5 Posts
Top