BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
18 Posts
Discussion Starter #1
The EHCS I put on my 01 K1200lt is not working. I plan to pull it off to work on it. My question is will the side stand have enough bracket support that I can I still ride the LT.
Thanks
 

·
Registered
Joined
·
511 Posts
Should not be an issue.
 

·
Premium Member
Joined
·
1,595 Posts
I am guessing that you think you have to remove the center stand..nope.

You can remove the EHCS with out taking the center stand off.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,256 Posts
If you are pulling the actuator here is a good Video Link that shows how to remove it. It is possible to do it on the side stand it is just hard to get the nut off the end of the shaft at the center stand.

When you say it is not working do you mean the motor does not run or the motor runs but won't lift the bike?
 

·
Premium Member
Joined
·
18 Posts
Discussion Starter #5
The motor does not run. The acturator was covered with oil when I removed it. I just had a new clutch and new seals put in so there is no more leak. Thanks for the video. I will do a search I know there a few threads about doing a rebuilt.

Elgin
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,256 Posts
I have encountered a few where the shaft seal on the drive gear to the pump leaked and the electric motor filled with oil. That will do it in and require a new motor. Don't bother with the little allen head ports as all filling and draining can be done though the 19 mm bolt near the base. There is a good write up in the technical files section.
 
1 - 6 of 6 Posts
Top