BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
568 Posts
Discussion Starter #1
Well, after several looks at some threads on this great site, I returned my Sena 20s (7 months old) to Sena and received a brand new one in 3 days after receipt of the old one. The reason I did: I was only using the GPS for voice and the iPhone for music and receiving and making calls and I wanted to fully utilize that Nav V features.....This was with the phone paired to the 20s and the Nav V to the 20s...

I called Sena on several occasions ( over 3.5 hrs of discussions)and was given a set of pairing instructions.....They worked for a while but when I turned off everything and reconnected, I could not hear incoming calls in the headset...I could hear phone ringing and see caller ID on phone and Nav V, but nothing in headset. When I tapped the "mute" button on the phone, I could see various selections with the check mark on Nav V...but nothing...If I tapped the 20s, I would now have hearing in the headset....The tech support at Sena had me un-pair everything, factor reset 20s and clear all pairings on phone and Nav V and start all over......frustration to the highest.

After receiving the new unit I called them and went through the same issues with no remedy...So, Sena said they would pass it up to a higher level and I should get a call within 24hrs.......

So, here are the pairing instruction Sena gave me:

A..Pair the iPhone to the 20s. (Please turn off the GPS bluetooth). Do the mobile phone pairing.

B..Pair the Nav V and the 20s via Second mobile pairing or GPS pairing. (Please turn off the iPhone's bluetooth). Do the second mobile phone pairing.

C..Pair Nav V and iPhone. (Turn off the 20s).

When I did this, it still did not work...... So I made a excel chart with all of the "TURN-ON" steps.....When I did this, had six options for turn-on sequences

A....turn on iPhone, Nav V and 20s........... in this order...wait for full turn on of each device...one at a time...this apples to all steps
B....turn on iPhone, 20s and Nav V............in this order

C....turn on 20s, iPhone and Nav V............in this order
D....turn on 20s, Nav V and iPhone...........in this order

E....turn on Nav V, 20s and iPhone............in this order
F....turn on Nav V, iPhone and 20s............in this order


I tried each step (A-F) 2 times except for item "C"....I did that 3 times....I also checked the Nav V to insure all calling out functions worked and that all receiving calls were accepted and heard in the headset......

Well......step "C" worked !!!!! turning on the 20s, then the iPhone and finally the Nav V works for incoming calls for both Nav V caller ID, iPhone caller ID and rings in the headset.......It also allowed me to use the phone book in the Nav V for making outgoing calls, use the dial feature in the Nav V for outgoing calls and the voice caller in the Nav V for outgoing calls.......I could hear the ringing in the headset for each outgoing call!..........The media function also worked and allowed me to put music on a HCSD chip and put into the Nav V and play, browse select music to play without having to use the phone for music and daring the battery.....

Now...please note, I have a new 2016 R1200gs loaded....It does not have a BMW music system or radio....only GPS prep and Nav V......I am very happy now, but it took a long time with Sena to understand I was NOT doing their pairing process incorrectly.....I believe when I give this process to them as feedback, they can come up with a software change that will allow you to turn off all equipment and turn back on in any sequence.......The 20s now does not "hold" memory for turn on or pairings in using my set up..Getting fuel could be an issue, but I can turn engine off and still keep Nav V on.

Hope I have not bored anyone but I wanted to share my story and what I did to get it to function the way it is advertised and to work with my bike, iPhone 6 plus and 20s headset......I am a happy camper now......
 

·
Premium Member
Joined
·
1,392 Posts
I'll have to try this process with my Cardo G9/Garmin 590LM/iPhone 6s Plus to see what works with that combination, as I seem to have problems getting the 3 units to work together. Thanks for sharing your trials with your 20s/Nav V/6 Plus combination. :bmw:
 

·
Registered
Joined
·
568 Posts
Discussion Starter #3
Hope you find out what works..It was painstaking though and I am having no issues now...good luck
 

·
Registered
Joined
·
568 Posts
Discussion Starter #4
I'll have to try this process with my Cardo G9/Garmin 590LM/iPhone 6s Plus to see what works with that combination, as I seem to have problems getting the 3 units to work together. Thanks for sharing your trials with your 20s/Nav V/6 Plus combination. :bmw:
"E" works also.....I just kept trying and it seems to be very good...Just let iPhone and Nav V pair before turning on the bluetooth on the iPhone
 
  • Like
Reactions: JNW003
1 - 5 of 5 Posts
Top