BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The Sirius satellite radio on my 2015 1200RT worked fine since I got it in September, 2015 until a couple of weeks ago. The satellite radio completely disappeared from all of the menus. There should be a whole section in Settings for Sirius, but it's not there anymore. And when I press SRC (source) for the radio (AM, FM, Sirius, etc.) Sirius is no longer listed as an option. It's not grayed out... it just does not exist anymore in any of the menus. And I can't get to Channel 1 in order to receive a reset code from Sirius. The FM radio still works.

This happened after I had the dealer reset the maintenance interval counter, since they had forgotten to reset it when I had the oil changed in June.

I called the dealer today. They said over the phone they have no idea what's going on, and I'd need to bring it there for them to work on it. But it's a three-hour round trip for me.

If there is any way this could be fixed without the three-hour trip (plus waiting there), that would be great.
 

·
Premium Member
Joined
·
5,040 Posts
The Sirius satellite radio on my 2015 1200RT worked fine since I got it in September, 2015 until a couple of weeks ago. The satellite radio completely disappeared from all of the menus. There should be a whole section in Settings for Sirius, but it's not there anymore. And when I press SRC (source) for the radio (AM, FM, Sirius, etc.) Sirius is no longer listed as an option. It's not grayed out... it just does not exist anymore in any of the menus. And I can't get to Channel 1 in order to receive a reset code from Sirius. The FM radio still works.

This happened after I had the dealer reset the maintenance interval counter, since they had forgotten to reset it when I had the oil changed in June.

I called the dealer today. They said over the phone they have no idea what's going on, and I'd need to bring it there for them to work on it. But it's a three-hour round trip for me.

If there is any way this could be fixed without the three-hour trip (plus waiting there), that would be great.
Obviously the dealer did something when they did the software update! So, it does need to be taken back to them to fix the issue!

Man, I wish that it would disappear from my radio! I do NOT use the service at all, and it would save me a step, when I go through my selection, if I can skip that one permanently!!! :)
 

·
Registered
Joined
·
1,181 Posts
I had this happen on my 06 LT after a service reset. They also had no clue as to what happened and the end result was they needed to order me a new sat/nav radio control, & new ESN/Radio ID making me have to reestablish my free 1 yr accountant (not easy).
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I had this happen on my 06 LT after a service reset. They also had no clue as to what happened and the end result was they needed to order me a new sat/nav radio control, & new ESN/Radio ID making me have to reestablish my free 1 yr accountant (not easy).
Thanks Joe. That helps.

It looks like I'm going to be putting in a lot of 180-mile round trips to the dealer to fix BS stuff.
 
1 - 4 of 4 Posts
Top