BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi Guys, before I dig into the Clymer I thought that a question was in order. Yesterday got caught in a down pour for about three hours. Radio was working fine at first then I went into work and when I came back out, No Display or Sound. The display back light is on but no LED display, when I press the power button for the radio I get some funny looking signs and figures very faintly and then nothing.

Any suggestions,

Al
Spokane WA
:confused: :confused: :confused: :( :(
 

·
Premium Member
2011 R1200RT
Joined
·
8,175 Posts
What year is your LT?
Try removing the fuse that powers the radio, to reset it and wee if things come back to normal...
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
It is a 2002 LTC, 29,825 miles. I don't have my Clymer at work where is the fuse located, under the seat perhaps.!!!! :confused: :confused:

Al
Spokane
WA
:dance: :dance: :dance: :dance:
 

·
Registered
1999 LTC
Joined
·
14,458 Posts
SpokaneLTC said:
It is a 2002 LTC, 29,825 miles. I don't have my Clymer at work where is the fuse located, under the seat perhaps.!!!! :confused: :confused:

Al
Spokane
WA
:dance: :dance: :dance: :dance:
Don't know if you have your Clymers at hand now, butt the radio fuse is under the passenger seat (you just lift the rider's seat to see the blocks) and is in the middle block, bottom fuse.
 

·
Registered
Joined
·
55 Posts
Stop riding in the rain!
Bad news, your radio is giving out. I had the same problem with mine, your control buttons have small cracks in them and it's letting water leak in onto your circuit board and corroding it.
You might get lucky and when it dries out it might start working again. The Jensen install will solve your radio problem.
 

·
Registered
Joined
·
375 Posts
Same issue...I was told by my now OUT OF BUSINESS stealership that the LT was not designed to be ridden in the rain. Not covered under warranty!!! I can't imagine why they went tits up.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
The fuse looks good. What the hell a bike made in Germany not supposed to be ridden in the rain. I have ridden in the rain for the past five years and worries. I think it is time to get an MP3 player and be done with it. I guess that my luck was good to have the radio last this long. Thanks guys. Any good dealers for the Jensen swap out, or is there another avenue other than Jensen.

Al
Spokane
WA
:dance: :dance: :dance: :bmw: :bmw:
 

·
Registered
Joined
·
94 Posts
I never had any problems with the radio on my '99 LT until I washed the bike and got a little water on the radio. I have seen the grayed out symbols across the display. Sometimes the radio won't shut off.

I took the radio out last winter and cleaned all the connections. That didn't seem to help.

To be honest banging the little BMW symbol above the radio with the palm side of my fist seems to fix it for awhile. I'm sure it is only a matter of time before it fails.

Maybe next winter I will open the unit up and spray some electrical connection cleaner on any suspect areas. :deadhorse
 
1 - 8 of 8 Posts
Top