BMW Luxury Touring Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hello all.

My radio in my 05 LT just crapped the bed. No sound at all.

Anyone know the model number of the radio so I can look for a replacement? I'm not willing to spend $1200 on a dealer replacement.

Any advise would be appreciated...

Paul
:confused:
 

·
Premium Member
Joined
·
4,886 Posts
You can search for "Radio Repair Found" or "Jensen" for info on getting radio fixed or replacing with aftermarket unit if you are willing to consider those approaches.
 

·
Premium Member
Joined
·
1,595 Posts

·
Registered
Joined
·
20 Posts
Try this link.

http://www.beckerautosound.com/BMW/index_K1200LT.html

I may have to replace mine and these guys have refurbished. My only concern with doing this is these guys say they are the ones that provide the BMW Radios but it sounds like BMW Radios crap out so why would I put in another only to have to replace again at some point in time?

I'd like to see the Jensen option and if it works with the BMW controls.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
I fully agree, I would love to get *ANY* other brand of radio other than BMW, but I really want the handlebar controls, and I am not very good at patching electronics.....

I tried emailing beckersound several times, and have never had a response. I guess tomorrow I will try calling them....

If anyone has a "plug and play" replacement of any brand other than BMW, I would be VERY GRATEFUL!!!!

-Paul
 

·
Premium Member
Joined
·
4,886 Posts
I was not referring to Becker. Search for the thread using something like "radio repair found" and you should find the posts about Baris.
 

·
Registered
Joined
·
137 Posts
I used Baris to repair my 05 radio. It now works great and he was very reasonable on his pricing. Turn around was 2 weeks.
 

·
Registered
Joined
·
80 Posts
I had my radio repaired by Becker last year. It takes awhile to take out of the bike, but if you ship it to them they should be able to repair it and send it back. They had some trouble getting the board from Germany so it took quite some time to get it back, but it was worth it in the end. Cost about $400 and worked like new. I would suggest calling the Service department to talk about it first. They are quicker to answer the phone than respond to an email. Good luck.
 

·
Registered
Joined
·
1,162 Posts
Drakba said:
Hello all.

My radio in my 05 LT just crapped the bed. No sound at all.
You're sure it not in a hung state? Sometimes under just the right conditions it will look like it powered on but won't play anything. You have to disconnect the battery and let it sit for 20min or so.

Greg
 
1 - 10 of 10 Posts
Top