BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
786 Posts
Discussion Starter #1
Finally got the antenna on the LT today. Bought the 99 in Nov, never had a chance to use the radio, and had to remove the antenna to get it to fit the storage area.

At least one, possibly both rear speakers are shot. What is the easiest way to disconnect the speakers?

Anyone have a set lying around they don't need and would be willing to sell inexpensively?

Thanks in advance!
 

·
Registered
Joined
·
659 Posts
They're pretty easy to get at. Remove about a dozen allen screws in the trunk that secure the speakers and they come off. I replaced mine with Kicker KS 525
for about $45 from Overstock.com. Others have replaced theirs with Alpine SPS-130A 5 1/4" 2-way speakers with good results. Check Ebay...there were some Kicker KS525 speakers available for about $20. The polypropylene cones are pretty much waterproof.
 

·
Premium Member
Joined
·
1,414 Posts
If the speakers just sound like crap, try hitting the roundel on the stingray. My '99 had the issue before I messed with the connections. This thread discusses some more permanent fixes.

HTH,
Jer
 

·
Premium Member
Joined
·
1,561 Posts
Or you could just use the radio controls to fade speakers to front only....
 

·
Registered
Joined
·
786 Posts
Discussion Starter #5
The rear speaker is shot, the fader is the solution for now. The vinyl is coming off around the corners on both speakers as well. Just have to live with it.

Haven't actually driven the bike with the radio on yet, so further evaluation will be needed to see if it is worth putting any more $$ into this 99.

Must have been one hell of a bike when it was new.

Thanks for the info!
 
1 - 5 of 5 Posts
Top