BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
Mine went dead after startup this am. I remember somewhere about pulling the fuse for a little while but cant remember which one. I would like to pull the battery terminal(negative side) but its getting late and i want to ride in the a.m. so was wondering if anybody knew exactly where the fuse is located so i can just do that then pop it back in in the am versus playing with the neg terminal in the morning. tks Mike
 

·
Registered
Joined
·
2,066 Posts
Pull your negative terminal tonight and let it sit until the morning. If you have an alarm system be sure to have the key fob handy for when you turn the key back on. Also...turn the key on...twist the throttle two times full travel....turn the key back off. Turn the key on again and then start the engine.

You don't have to wait till the morning but at least give it 30 minutes.

Ron
 

·
Registered
Joined
·
929 Posts
kellenbenz said:
Pull your negative terminal tonight and let it sit until the morning. If you have an alarm system be sure to have the key fob handy for when you turn the key back on. Also...turn the key on...twist the throttle two times full travel....turn the key back off. Turn the key on again and then start the engine.

Plus 1 on what Ron said...
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,101 Posts
Plus 2 -- The Fuse you can get to is not enough as there is another feed separate from it and that fuse is in the radio backside.
 
1 - 4 of 4 Posts
Top