BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i just bought a 2002 with the single cd player in where the cassette player was. everything works but it only plays out of the front left speaker.can anyone tell me what i need to replace.
 

·
Premium Member
Joined
·
1,595 Posts
Last I checked Becker had a flat rate around $400.
 

·
Registered
Joined
·
137 Posts
My 05 is only playing out of the rear speakers. I hate to spend $400 on that problem. I might pull it and see if any local shops can fix the problem.
 

·
Premium Member
Joined
·
2,945 Posts
Try toggling from left to right. . .

Press (musical note sign) to toggle between Bass, Treble, Fade, Balance, Loudness. Use thumb dial, L or R to adjust setting. If you press and hold (musical note sign) for more than 2 seconds, all parameters will revert to default (midrange) settings

If that doesn't work, disconnect the battery for an hour or so and reconnect. Worked for me! :)
 

·
Registered
Joined
·
5,857 Posts
dielectric grease


Pull the stingray off and remove the radio go all the way to plug in at the back of the radio unit. Clean all connections and use dielectric grease on every connection as you reassemble. Then go under the back seat and use it on the connection to the rear speakers.

This has repair both the LT's over the years.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,135 Posts
Painterman said:
My 05 is only playing out of the rear speakers. I hate to spend $400 on that problem. I might pull it and see if any local shops can fix the problem.
They won't be able to due to the type of IC used for the final amp. It is impossible to replace since it is a ball grid array mounting type. Becker doesn't een replace the IC they just replace the board for $400. Better to go the Jensen Marine radio way unless you are intent on keeping her stock.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Sorry it took so long to get back to it. Took a while to get to the plugs and connectors and just did the same thing. Tried calling Becker the number didn't work. Think I'll just try the Jensen. Any suggestions on the install will be appreciated.
 
1 - 8 of 8 Posts
Top