BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
493 Posts
Discussion Starter #1
Pushed my '05LT off the centerstand while leaving the big orange box yesterday and the radio lost all sense of control. Would not respond to the volume, seek or mute control on the handgrip nor any of the buttons on the stingray except the on/off. The rest of the handgrip controls were fine - Windscreen, BC toggle, lights ...

Tried turning the bike off, putting it back on the stand, several cycles with no effect. It would randomly seek for stations while I was fiddling with it. Left it on for the 15 minute ride home and it seemed to go into seek mode over every bump. It kept its settings like memory presets and front speaker off. Volume stayed constant.

Got home, shut it down, turned it back on and everything is fine! Was also fine on my ride into work this morning.

I had my cargo strapped to the passenger seat with bungees from the top rack to the panier handles. I also have the Baehr intercom system installed.

Any clue as to what happened? Do I need to go unseat and reseat some connectors? Any thoughts?

Thanks,
 

·
Registered
Joined
·
493 Posts
Discussion Starter #2
DaveDragon said:
Be careful not to let cargo on the rear seat get up against the radio controls.
I'll bet that's it exactly. I had a couple of small poplar boards laying across the back and a Porter Cable belt sander box tied down to the passenger seat. Was probably hittin' the controls as I rode around. I can clearly see it happening once I saw your post and re-read mine. LOL What a maroon ...

Thanks.
 

·
Registered
Joined
·
797 Posts
The previous owner of my LT told me that he once took a long trip with luggage strapped to the back seat and was
using it as a back rest. He said sometime when he leaned back the radio volume would go off. He said it drove him crazy all day until he unloaded and figured out what had happened. He thought it was funny - later. I have generally been careful packing after his warning.
 
1 - 3 of 3 Posts
Top