BMW Luxury Touring Community banner
1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
After 1 1/2 weeks at Becker, the radio for my 2003 K1200LT is finally back. Now I have to put her back together again...... Are there any printed procedures or links that will guide me through this???? I don't want to mess this up now.
 

·
Registered
Joined
·
1,106 Posts
Good luck Milton. Sorry I can't help you, but all I remember about when I got into mine, some years ago, was that doing the weep hole procedure was a lot easier :(
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
Alright, all the wires are back together. Mt problem is putting the correct screws back into the radio harness, and reconstructing the stingray. Will the manual show me which screws go where?

[email protected]
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #6 ·
Thanks. I'm almost there, but there is what looks to be a ground wire (very small hole) coming from the rear of the comm system that does not have a home. Would you happen to know where that goes?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,063 Posts
If it is a brown wire then it would be a ground. I have no reference data on the comm system but it wouldn't hurt to find a small screw on the radio itself to hook it to. I checked the wiring diagram and it shows one brown wire from the intercomm to a tie point with other brown wires. Just not sure where that physically is. Guess you don't remember where it came of off.

I like to take digital picures of things llike this BEFOREI take them apart as I find it is much better than my memory. Saved my bacon in the Throttle Body area during my clutch job as there was a lot of "stuff" that needed to be hooked back up and dressed properly to fit.
 

·
Registered
Joined
·
275 Posts
joh0665 said:
After 1 1/2 weeks at Becker, the radio for my 2003 K1200LT is finally back. Now I have to put her back together again...... Are there any printed procedures or links that will guide me through this???? I don't want to mess this up now.

Has this been completed and has the radio worked as planned, wondering if Becker replaces with a better board and/or amp. ?????
 

·
Registered
Joined
·
275 Posts
joh0665 said:
It's back together. So far so good. Sounds good too

Sent my 05 radio to them after seeing this thread and 8 days later it's back and sounds ok again. They called for payment and told me it was repaired and ready to ship and then told me how much, $400 for the radio, $50 for the aux jack that I never asked for and $16 for shipping.


If you send your radio to them be clear in your note to them if you don't want the aux jack, otherwise it's $50 bucks for something you don't need if you have the intercom. I also heard this aux jack is mono and not stereo from another site.

Overall I'm happy, service was fast, a bit expensive though.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,063 Posts
STEBS said:
If you send your radio to them be clear in your note to them if you don't want the aux jack, otherwise it's $50 bucks for something you don't need if you have the intercom. I also heard this aux jack is mono and not stereo from another site.

Overall I'm happy, service was fast, a bit expensive though.
You may find a buyer here for the AUX cable since it plugs into the same port on your radio as the intercom. It should be a stereo cable.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top