BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
590 Posts
Discussion Starter #1
When I installed the IceLink, I set up five playlists as recommended by Dension. I can work those OK with the IceLink, although it sometimes wants to jump the first song when I change "disks" (playlists). I did not do much with the "Disk 6" IceLink menu at first.

My IceLink came with firmware version 2.05. I downloaded the zip file with the 2.B2 update and loaded that into the iPod. The instructions for updating required me to hook up the iPod to the IceLink (done), then go to Disk 6 for the Dension IceLink setup menu (done), scroll down to "Update Ice Line" (done), then select. That's where I'm stuck.

I can't make it select any menu item in the Dension menu. As I read the instructions, you tap the right side of the handlebar remote to scroll down (that works OK). You then hold down the same control to select. When I do that, it goes to another disk. I tried selecting other menu items from the menu that appears on the iPod, without success. Am I missing something?

The Dension instructions suggest that my scroll wheel controls should also be active, unless the Dension IU interface is selected, but my iPod controls don't appear to work at all when the Ice Link is connected (other than turning on the backlight).

Any suggestions?
 

·
IBR# 366
Joined
·
16,570 Posts
The LT uses the handlebar switch for multiple functions, instead of a bunch of individual buttons. I don't remember the exact sequence, but try this. Do everything the same as before, including tapping the right side of the handlebar remote to scroll down. Then press the MAN button on the radio console (near the display), then press (or possibly hold) the right side of the handlebar remote to select. Pressing MAN first changes the mode that the radio buttons are in, and may be the secret trick.
 

·
Registered
Joined
·
874 Posts
I have the exact same problem, tried the MAN trick, didn't work. Have written to Dension twice, including to "Chase" the supposed inside contact for us. Still no reply and no way to get into the menu choices. All I want to do is change my charging selection. Other than that, it is working great with possible exception of cutting out once in a while, acts like "CD skip" but has nothing to do with vibration, bumpy roads, etc. Also others have had problems with lock up after an hour or so but mine has run for several hours with a load of luggage. The IPOD got pretty warm but never failed. Oh, BTW, my bike is an '05, has some affect on the way the Ice>Link works.
 
1 - 3 of 3 Posts
Top