BMW Luxury Touring Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
has any one had trouble with front power socket? I have 2005 LT, since november of 2004, and have used trikle charger on it every year. I cant seem to get a charging reading(light inicator) , it's not the charger because I tried another one that I use on a jet ski.The red indicator lights which indicates power is coming to it. It is a Yusa charger with three light, red for power, yellow for charging, and green for sleep mode.
Thanks
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,171 Posts
Are you sure it is plugged in? It must be unplugged to remove the lower fairing for maintenance and some times they forget to hook it back up. You can see the back side of the socket looking up through the opening in the faring.
 

·
Registered
Joined
·
747 Posts
Check the socket for corrosion or the wire may be disconnected behind the tupperware. I had the bike serviced and the tech forgot it put the wires back on.



jpgcycle said:
has any one had trouble with front power socket? I have 2005 LT, since november of 2004, and have used trikle charger on it every year. I cant seem to get a charging reading(light inicator) , it's not the charger because I tried another one that I use on a jet ski.The red indicator lights which indicates power is coming to it. It is a Yusa charger with three light, red for power, yellow for charging, and green for sleep mode.
Thanks
 

·
Premium Member
2011 R1200RT
Joined
·
8,175 Posts
I am taking bets...!:D
The rider's powerlet was not connected when I picked up my 03 in Pittsburgh. I was wondering why the Gerbing jacket liner and pants would not heat up... Good thing the passenger powerlet was live.
I am still grateful to Jeff for loaning me the heated gear:thumb:
jpgcycle said:
thanks, i did have in for service, i will check.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
a ha, I found it, socket had power, the plug that I also use to go from the bike to my heated jacket had a disconnected wire in the male end. Fixed it and now get power to the bike from the charger.
Thanks for all the suggestions.
John
 

·
Registered
Joined
·
809 Posts
Are the power sockets switched through the ignition?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,171 Posts
If you look at the BMW wiring diagram they are NOT. But in reality the front one is hot all the time and the rear one is switched. So much for the accuracy of the wiring diagrams.
 
1 - 9 of 9 Posts
Top