BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter #1
Hi all
as always looking for your help

When I try to use the electric centre stand on my2005 k1200lt, I get a low voltage warning on the dash and so it does not deploy,
done the obvious, cleaned battery connections checked grounds, etc, light comes on but flashes fast
anyone know where relay is located? cruise quit at same time, I can not find any relationship on wiring diagrams
anyone had a similar problems
Help needed, leaving on 4000 km trip 6 am tomorrow
 

·
Registered
Joined
·
343 Posts
Hi all
as always looking for your help

When I try to use the electric centre stand on my2005 k1200lt, I get a low voltage warning on the dash and so it does not deploy,
done the obvious, cleaned battery connections checked grounds, etc, light comes on but flashes fast
anyone know where relay is located? cruise quit at same time, I can not find any relationship on wiring diagrams
anyone had a similar problems
Help needed, leaving on 4000 km trip 6 am tomorrow
I would Suspect the battery strength as you do not have much time and would put it on a charger over night. Hopefully this would address your issue or at least see if there is any further time needed before confidently taking the LT out on such a long ride.
 

·
Premium Member
Joined
·
7,623 Posts
Hi all
as always looking for your help

When I try to use the electric centre stand on my2005 k1200lt, I get a low voltage warning on the dash and so it does not deploy,
done the obvious, cleaned battery connections checked grounds, etc, light comes on but flashes fast
anyone know where relay is located? cruise quit at same time, I can not find any relationship on wiring diagrams
anyone had a similar problems
Help needed, leaving on 4000 km trip 6 am tomorrow
Sounds like you need to invest in a new battery before you leave.
 

·
Registered
Joined
·
10 Posts
Hi I have a 07 LT. Centre stand deploys, but doesnt fully retract when I rock her off it! Means side stand out, dismount and ease up with foot before setting off. Do I need to remove, dismantle and play with it, or is it a replacement part that needs fitting? (Not a great tech head as you can tell!)

Sent from my SM-N960F using Tapatalk
 

·
Premium Member
Joined
·
630 Posts
Dave, I would lube the pivot points first before I took it apart. Should just use a spring or two to bring it up.
 
  • Like
Reactions: DaveIves
1 - 5 of 5 Posts
Top