BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
659 Posts
Discussion Starter #1
Hi Guys...long time no been around but glad to be back.

I need to replace O2 sensor I believe, for my 2003. Can anyone verify the part as Bosch 13475?

Thanks!
 

·
Registered
1999 LTC
Joined
·
14,459 Posts
Reid said:
Hi Guys...long time no been around but glad to be back.

I need to replace O2 sensor I believe, for my 2003. Can anyone verify the part as Bosch 13475?

Thanks!
That's the one I bought on Amazon. Came complete, and I used the instructions that are here on the forums somewhere. As I recall, it did not involve removing the exhaust unit, butt wuz kind of a pita doing it that way. Prolly easier by removing the exhaust. It did require some tupperware removal. Good luck.
 

·
Premium Member
Joined
·
3,108 Posts
Can't verify the part# but as a rule just count the number of wires on it and it will be interchangeable if it has the same number of wires. You may just need to solder up the wires if the fitting is different. Make sure you stay as far away from the new sensor as possible with the splices.
 

·
Premium Member
Joined
·
1,561 Posts
Beemer Boneyard has new Bosch O2 sensors that fit all K bikes....................
They are retrofit though and require splicing wires instead of removing tank and replacing entire harness.
I used one on my '03 LT and it's still functioning 3 years and 50,000 miles later later........
 

·
Registered
1999 LTC
Joined
·
14,459 Posts
Reid said:
Hi Guys...long time no been around but glad to be back.

I need to replace O2 sensor I believe, for my 2003. Can anyone verify the part as Bosch 13475?

Thanks!
Did some searching and found this good read. Even has some posts regarding how to test an O2 sensor, so scroll down thru the thread. Again, good luck.
 

·
Registered
Joined
·
659 Posts
Discussion Starter #6
Dean, Dick, Allan....thanks for the info! Good read on the sensor, Dick. Not sure if my gas mileage drop is due to sensor yet...so I'll do the test. I did the recalibrate but can't get over 40mpg regardless. No idle problems, but motronic might be compensating.
 
1 - 6 of 6 Posts
Top