BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,916 Posts
Discussion Starter #1
I was moving it off my motorcycle to the car. I got distracted and left it on the roof as I drove off. I slung it cross the parking lot. It still works however, there is a small yellow spot, not a solid, and it is getting bigger. Has anybody done this????
 

·
Premium Member
Joined
·
5,852 Posts
motorman587 said:
I was moving it off my motorcycle to the car. I got distracted and left it on the roof as I drove off. I slung it cross the parking lot. It still works however, there is a small yellow spot, not a solid, and it is getting bigger. Has anybody done this????
Sounds like a broken LCD display. You will be able to use it for a while until the spot gets too big, then repair or replacement will be needed.
 

·
Registered
Joined
·
568 Posts
I had my center dtand break at the weld crossbar and the bike went over to the right and came to rest on the windscreen against my workbench,. All is well now, replaced windscren adjuster, center stand, windsheild and only need the right rear speaker housing. I checked my GPS and it worked with bike power......checked it in the car and worked with the cigarette lighter power.........checked it on brand new charged batteries and it will not turn on.....

Its a SPIII and I love it. Sent to Garmin and it is going to cost @225 for a tune-up! Jason told me that they would fix the batter power-on and make sure all systems are current revisions. WoW....
 

·
Registered
Joined
·
2,916 Posts
Discussion Starter #4
Thanks, that is what I was thinging too. Sounds $$$$
 

·
Premium Member
Joined
·
5,852 Posts
motorman587 said:
Thanks, that is what I was thinging too. Sounds $$$$
Sorry that I can't give you better news. It would have been a slight chance that you have "just" an electrical problem, but the fact that you said the spot is getting bigger tells me pretty much that the LCD is broken.
 
1 - 5 of 5 Posts
Top