BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
528 Posts
Discussion Starter #1
I've installed a New Nuvi 660 on my '12 RT and I'm having an odd Canbus issue.

I connected it using the BMW repair plug (using only the 1 & 3 leads) to the switched GPS plug down by the steering head and behind the headlights. The GPS powers on and off fine with the key.

The issue that I'm having is that when I first plugged in my BMW Charger to the accessory outlet it powered up the GPS ( with the key in the off position and the bike off ). I thought maybe I had plugged it in before the whole Canbus had shut down and re activated the circuit....so....

I unplugged everything for 1/2 hr and removed the GPS from the cradle. The bike charged normally and went into sleep mode. At that point I replaced the GPS and the charger stayed asleep.

Today when I came home the charger was going through its cycle( as it does normally every now and then) AND THE GPS WAS ON AGAIN with the key in the off position.

Any ideas on how to cure this? Other than to remove the GPS from the cradle every time I park the bike?

Thanks in advance for whatever help you can lend!
 

·
Registered
Joined
·
528 Posts
Discussion Starter #2
No help? Has anyone else had this happen?
 

·
Registered
The Villages, FL
Joined
·
2,601 Posts
Sorry Bob for no replies yet. Is it only the gps that is waking up? Do you notice anything else waking up? The bmw charger has to wake the canbus in order for it to charge the battery, but just how much it has to wake I do not know. I also thought that when you first connect the charger that the key had to be on, or at least the canbus was still awake.
This is why I plug in my charger to a pigtail coming directly off the battery. You can also plug in power hungry items into the pigtail. I hope that someone can figure this out for you.
 

Attachments

·
Registered
Joined
·
528 Posts
Discussion Starter #4
Thanks Mike -

I do have a pigtail coming off the battery as you do and might try plugging a regular old battery tender charger into that to see what happens.

I've resisted using it in the past as the warnings that came with the BMW Charger have stern warnings about potential damage to bmw electronics when using any other charger. Hopefully going straight to the battery isn't going to harm anything.

I'm going to give it one more try today as I have some errands to run. I'll take the bike. I found an older thread where Hopz advised leaving the Zumo alone and allowing it to turn itself off. Hopefully that will allow all circuits to close themselves and remain off.

I don't have any other accessories ( lights, horns etc) so I'm not sure what might still be live. The charger re powered the Zumo from both powerlet ports, I was hoping it might be some cross feed from the dash port...but that wasn't it.

One last question - Mike, are you using a BMW charger into that pigtail ,another Canbus friendly brand, or just a standard battery tender?

Thanks for the reply, I appreciate it!
 

·
Registered
Joined
·
1 Posts
hello- I have a 2011 rt with factory nav 4 which is the same as the 660. I use a cambus charger plugged thru the bikes outlet. My owners guide states you should leave out the nav unit when charging the bike. I did not do that one time and the nav unit stayed on. So, It is now left out when charging. hope this helps- don
 

·
Registered
Joined
·
528 Posts
Discussion Starter #6 (Edited)
Thank you MoRoad that does help! Did you find that in the RT's Manual or a separate one you got with the Nav IV?

Right now I have the bike plugged in to a regular old fashioned battery tender. I checked with the Dealer and they said that would be fine.

I will review the manual though. Probably would have been the place I should have started! :D

Excellent first post by the way!
 
1 - 6 of 6 Posts
Top