BMW Luxury Touring Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2003 Lt,and recently I have been having intermittent radio problems. From time to time the left speakers quit working. Is this a radio problem or a wiring problem.
 

·
Registered
Joined
·
92 Posts
My radio had the right forward speaker quit along with other problems. When I replaced the radio the speaker started working again.
 

·
Registered
Joined
·
3 Posts
its the radio my 2002 did the same thing i left like that for a couple of months then i wired the left and right speakers together then a week later the radio quit working
 

·
Registered
Joined
·
67 Posts
Just called Becker of America (mentioned in previous thread) and they said to send in the unit for repair @ a min. cost of $440. I have an '02 LTC and had the unit replaced 4 times under warranty. Don't know if I can swing the cash for this one, may explore other options. MG.
 

·
Registered
Joined
·
170 Posts
I just went through this very same scenario with my 2003 I removed it and sent it for repair, Cost just under $500.00 with freight by the time I got it back and it works great but it took three months for it to get done and sent back. In the interim I bought a used one to install but decided to wait for the rebuilt one to come back, however if it happens again I won't have to wait.
 

·
Registered
Joined
·
1,334 Posts
baddad said:
its the radio my 2002 did the same thing i left like that for a couple of months then i wired the left and right speakers together then a week later the radio quit working
Do a search here for Jensen Marine Radio. A few of the guys on here have replaced the original with it for about $150. (With some modifications). Has an ipod cable & a place to hook up xm radio too. I'm going to replace mine with it this winter. I'm using my creative zen & 'sure' earbuds right now.....which is excellent.
 

·
Registered
Joined
·
1,900 Posts
All of you with failures..Are these the raidos (the head units) with the CD player in them and not the tape deck?
 

·
Registered
Joined
·
170 Posts
That was the case with mine, also the onset of the problem on mine coincided with the failure of the battery, but although others had been able to reset theirs by disconnecting the battery for some period it did not help mine.
 
1 - 9 of 9 Posts
Top