BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Good Day All: This is my second post so please bear with me. I have a 2003 LT that was purchased with no Trip Computer. I decided to add one but also required a change to my right hand switch gear as I did not have a BC button. Okay so this you guys know. So here is the problem(s), the BC button is not talking to the trip computer, when I press the button nothing happens on the trip computer. Everything else on the switch gear works but the BC button.

Also the computer reads-40F continually. Every other function on the computer works from the unit except the ambient temperature. Does some one know if an air sensor comes prewired on a bike without a trip computer? I have read that there is an air sensor in the nose under the front light. I did not see one.

Lastly the right hand switch gear came from a 2004 LT while the trip computer came from a 99LT, would that make a difference. I would appreciate any advice you guys can give...one thing for sure is this bike is sweeeet :dance:
 

·
Just ridin'
Joined
·
5,297 Posts
Newbie said:
Good Day All: This is my second post so please bear with me. I have a 2003 LT that was purchased with no Trip Computer. I decided to add one but also required a change to my right hand switch gear as I did not have a BC button. Okay so this you guys know. So here is the problem(s), the BC button is not talking to the trip computer, when I press the button nothing happens on the trip computer. Everything else on the switch gear works but the BC button.

Also the computer reads-40F continually. Every other function on the computer works from the unit except the ambient temperature. Does some one know if an air sensor comes prewired on a bike without a trip computer? I have read that there is an air sensor in the nose under the front light. I did not see one.

Lastly the right hand switch gear came from a 2004 LT while the trip computer came from a 99LT, would that make a difference. I would appreciate any advice you guys can give...one thing for sure is this bike is sweeeet :dance:
I cannot help you with the first question. There are two power supplies to the BC, one from fuse F1 and the other from Fuse F5. If those fuses are in place, you would have to see if there is supply to the BC on pins 5 and 10 of the connector when the bike is on.

The temperature probe is up under the nose and I have never seen one on a bike without a BC.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Randy...sounds like something else I need to make this work. I will check it out.. :rotf:
 
1 - 3 of 3 Posts
Top