BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Road 500 miles yesterday, 1/4 of it in the rain. Hey this is Southern Cal, its not that time of year. Anyway, I go to park the bike and turned off the key, but the radio is still on. What the ????? Turned the key back on pushed the off button on the dash. The light goes out on the display but the radio is still playing. Tried pushing lots of buttons and playing with the key, finally lifted up the seat and disconnected the battey. Haven't looked at it today. Thought I would ask if anyone has had this happen to them, and what can be done to fix it.
 

·
Premium Member
2011 R1200RT
Joined
·
8,158 Posts
Alas too common on early models (99 and 00). Try pulling the fuse for the radio and wait about an hour before reconnecting. This should reset the radio.
 

·
Registered
Joined
·
1,369 Posts
Better than having it RE possessed. :wave
 

·
Registered
Joined
·
594 Posts
My bike does that systematically under following conditions:
- radio is on
- I do connect the battery tender in to the auxiliary power socket
- I lock the steering (=all power is cut off also from auxiliary sockets)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks for the info. But.....I finally got a chance to reconnect the battery and start it up. She firied up real nice but when I glance over at the computer display it looks like a slot machine. The display is cycling faster than Lance Armstrong. Any one got any ideas.
 
1 - 5 of 5 Posts
Top