BMW Luxury Touring Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,550 Posts
Discussion Starter #1
I'm trying to troubleshoot a problem getting my cell phone to work with the ComSystem that was manufactured by J&M and sold by BMW for LTs from about 2002-2005. There is a 2.5mm jack on the face of the unit just for this purpose.

To make a long story short, I need to find someone who has a working system so I can plug in my helmet and phone to compare performance. This will take about 10 minutes at the most. I'll ride to wherever you are OR we could meet at this week's HDDC at a venue TBD.

Is there anyone on the forum that still has a working system and uses their cell phone with it?

TIA

Cheers!
 

·
Registered
Joined
·
860 Posts
I did... in the past... It was a Motorola V551 cell... worked like a charm... HOWEVER... that does not mean all cell phones will work with this COMM system. Since my V551, I have not be able to get any other data type device to work. Raz'r... nope. Motorola Windows based data phone? Naw... not even a whimper. I currently run a Galaxy S and there is no chance in hell it will work...

Unless you have a no frills phone, and I mean a real no frills older version cell phone (and for awhile I switched my SIM card from my main phone to the V551), do not expect it to function with the COMM system on the LT. iPhone? Don't even try.

just my $.02...

and...

just sayin...
 

·
Registered
Joined
·
71 Posts
i have had several phones working with the system , i t is pretty full proof but i currently have a problem with cable input on the comm system. i have not fixed that but have gone to a blue tooth headset. you may want to confirm that the cable and the input on the comm system are ok.
 

·
Registered
Joined
·
1,550 Posts
Discussion Starter #4
So here's the deal, I'm trying to troubleshoot my ComSystem cell phone connection. It's worked in the past but it's been a couple of years since I've used it. Today it actually works BUTT I have to yell into the mic for the person on the other end to hear me. I need to determine if the cause is the cord connecting the phone to the ComSystem or if it's the ComSystem. I've eliminated the mic since people can hear me very well over GMRS and rider to passenger.

Unless someone has a better idea I think the easiest way to verify if it's the ComSystem is to plug the my cord into someone elses working ComSystem. If I still have to yell then it's the cord. If I can be heard without yelling then it's my ComSystem.

Isn't there anyone in NorCal with a working ComSystem?

BTW: My droid works (except for the yelling) and J&M makes a cord for the iPhone so I know that smart phones can work. Getting all of the functionality (voice commands, having the phone ring in the headset, etc.) has always been problematic for me but I'm not expecting that to work.

Cheers!
 

·
Registered
Joined
·
36 Posts
I have a comsystem in 2003 LT. I have had two phones that work with it. One was a Razor, and my current phone is a LG. Never had a problem with either, except the phone never rings, since I set it to Auto Answer. Radio just cuts out, and incoming call is there. I'm not sure that you want to drive here to try mine out, since I live in Illinois. You may have to wait until all this ugly snow melts.
 

·
Registered
Joined
·
2,084 Posts
ltcommuter said:
So here's the deal, I'm trying to troubleshoot my ComSystem cell phone connection. It's worked in the past but it's been a couple of years since I've used it. Today it actually works BUTT I have to yell into the mic for the person on the other end to hear me. I need to determine if the cause is the cord connecting the phone to the ComSystem or if it's the ComSystem. I've eliminated the mic since people can hear me very well over GMRS and rider to passenger.

Unless someone has a better idea I think the easiest way to verify if it's the ComSystem is to plug the my cord into someone elses working ComSystem. If I still have to yell then it's the cord. If I can be heard without yelling then it's my ComSystem.

Isn't there anyone in NorCal with a working ComSystem?

BTW: My droid works (except for the yelling) and J&M makes a cord for the iPhone so I know that smart phones can work. Getting all of the functionality (voice commands, having the phone ring in the headset, etc.) has always been problematic for me but I'm not expecting that to work.

Cheers!
I have the J&M BC3 in my 02. I believe it's what you're looking for if you haven't cracked the code yet. 05s and later went to the VOICE II.
 

·
Registered
Joined
·
1,550 Posts
Discussion Starter #7
Thanks for reaching out Bob. I'll PM you later with questions and logistics.

Cheers!
 
1 - 7 of 7 Posts
Top