BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
351 Posts
Discussion Starter #1
My 05 ,s light is not working as i found out last year on my way to the ferry port in Dover .Recently i decided to replace my cd/radio for a new unit (£500.00 )and thought whilst the bike is apart i would change the fuel filter. I removed the filler tube on the top of the tank thinking that the tube was damaged as my low fuel light was not working . The tube was perfect with no damage and the wiring connectors were all good and the float sliding up and down the tube with no problems , so what could be causing this problem . I have noticed that on the wiring diagram there is a relay ,so could it be this causing the problem

Regards numbnuts in blighty .
 

·
Registered
Joined
·
2,066 Posts
Could it possibly be the bulb itself?

Ron
 

·
Registered
Joined
·
351 Posts
Discussion Starter #3
lights up when ignition switched on , don,t forget that my bike is the uprated model with the different dash .
regards numbnuts in blighty .
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,097 Posts
The trip point for the low fuel light is set with the MoDitec computer by the dealer. You have to take it in with the fuel level just where you want it to trip and they can set it.
 

·
Cat Herder
Joined
·
1,458 Posts
I have had the same problem with the fuel gauge for years. Have had the dealer fix it 5 times in and out of warranty. It will work for a week then stop. I quit trying and just know that in 200 mile I had better find a fuel station.
 
1 - 5 of 5 Posts
Top