BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Hydraulic center light flashing

I recently changed out my battery to an odyssey and took my first ride today worked good for 20 miles and then the hydraulic center stand light began flashing. I pulled over to ensure the center stand was up. I tried lowering the center stand with the bike running and in neutral and it would not descend. I put the bike in reverse and tried the stand and it worked and the light stayed out temporarily 3 or 4 minutes. Its back on now and I drove another 20 miles now even when I try it in reverse the stand will lower but doesn't have the power to lift the bike. The graphic for temperature were also spiking up down etc...but no warning lights.
 

·
Registered
Joined
·
308 Posts
do you mean center stand?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,256 Posts
It should not work in gear or in reverse (have not tried it yet). Sounds like the controller may be going out. Have not seen one so far on this board but there is always a first time. May want to check all your battery connections if you just changed it out. As strange things happen when one of the many wire on the positive terminal are accidentally left off. Stock there should but at least four red ones and one black yellow with a red sleeve.

If the motor (electric on the unit) is running and it will not fully lift the bike then it has lost fluid and should be re-built.
 
1 - 4 of 4 Posts
Top