BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So here's the problem. The battery in the key fob was getting weak, so I had the dealer replace the battery in the hopes that I would not lose the programming, or connectivity to the bike. I get home, hit the buttons, and nada. No alarm, no ability to lock the side bags etc etc etc. Anyone have any hints on how to get the key fob to talk to the bike? :(
 

·
Registered
Joined
·
1,106 Posts
According to my book on the alarm system, you must synchronize the FOB after replacing the battery. Hopefully who ever replaced the battery, got the polarity correct.

Try this, get close to the bike, press both A&B buttons on the FOB simultaneously and keep both pressed approx. 10 seconds until the LED goes off then release the buttons. The LED should shine steady.

Now press either one of the buttons and the led should go off. Now try the remote, it should work.

Hope this works for you.

You may have to remove the battery and reinsert it to get the remote to sync.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks I will give it a try. I hope you are right about the polarity. If your 1st suggestion does not work, I will take the battery out and reverse it, and see what happens.
 

·
Registered
Joined
·
1,106 Posts
Don't just reverse it, check to see if it is installed correctly. When you open the cover the + side should be visible (up). If it is installed backwards it can cause permanent damage to the remote. :(
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks folks. I removed the battery (the polarity was correct). Once I had reset the sync, all is well in the world once again.
 

·
Registered
Joined
·
1,106 Posts
stockbiker said:
Thanks folks. I removed the battery (the polarity was correct). Once I had reset the sync, all is well in the world once again.
Good news, glad it worked for you. :D
 
1 - 6 of 6 Posts
Top