BMW Luxury Touring Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all,

I'm a total newcomer to the K series so need a bit of knowhow. I've just picked up a Grinnall Scorpion III that hasn't started for a number of years.

The engine is free to turn, all ignition systems now seem to be powering and the fuel system is pumping away right up to the fuel rail. When I crank on the key nothing happens so I'm assuming there is a wiring fault in the signal wire to the relay attached. Sadly my DVM has gone walkies this evening so I will have to check that later

By firing +12V onto the starter it will crank OK but no sign of life. I haven't done a spark check yet because it will mean dropping the underslung fuel tank to get to the plugs but that will be on the to do list soon I'm sure

Any thoughts welcomed!

James
 

Attachments

·
Premium Member
Joined
·
630 Posts
Following this diagnostic flow chart may solve your issue.

troubleshooting starting

Motobrick.com specializes in older k bikes.
 
  • Like
Reactions: Patric

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Need a bit of help with this one - all fuses are good, fuel is pumping at pressure to the rail and there is a break in the signal to the starter so I have bypassed that to get reliable cranking.

I have no voltage at the injectors (all read 16 Ohms), has anyone got a photo of the FI relay? Obviously nothing is where it would normally be on a bike because this is a car and I'm struggling to find a few bits.

A few specific queries - what is the 2 pin plug on the coil packs for? (see pic)

There are two 5 pin connectors which are interchangeable, which is right?! (pic 2)

I'm struggling to find a complete wiring diagram, any pin outs available for the ECU or the plugs in pic 3 for ignition?

Thanks in advance

JAmes
 

Attachments

·
Premium Member
Joined
·
1,497 Posts
what is the 2 pin plug on the coil packs for? it is an Acc. 12 volt outlet for electric vest that kind of thing.

There are two 5 pin connectors which are interchangeable, which is right?
Got me, But I would think the color of the wires should stay the same...more or less

The last picture looks like a mess..I can't help you there at all.

You could have a bad safety switch like neutral , clutch , If all is not right it will not crank.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks for the ersponse

Sadly the wire colours are completely different, is there a schematic anywhere with wire colours for a Motoronic? I can't seem to find one

Any ideas which pin on the ECU receive the neutral/clutch/side stand/kill signals as I don't have any of those components
 

·
Registered
Joined
·
1,238 Posts
  • Like
Reactions: Patric
1 - 9 of 9 Posts
Top