BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I just purchased an 08 LT with 24,000 miles. It is excellent shape, except the electric center stand does not work. I have been reading some of the post here about fixing it. May give it a try in the near future. The dealer I purchased it from let me take it for a test ride three weeks ago. Two days later I broke my foot, so now my new ride is sitting in the basement waiting on me to get off of crutches. Yamaha's have been my ride of choice for the last twenty years. I was looking for a nice used Gold Wing, when I found the BMW at a dealer in Knoxville TN. It is great looking motorcycle that I hope to ride for several years.
This forum seems to be full of information and civil people that I hope to see some of on the road someday. My wife also rides and we are fortunate enough to live right in some of the best riding in the eastern part of the country. I can be on the Blue Ridge Parkway in 40 minutes. Deals Gap in an hour and a half and 7 miles from my house is a road 24 miles long that is as crooked as any road I have ever ridden.

Joe
 

·
Registered
Joined
·
4,426 Posts
Welcome Joe, from Sugar Hill, GA. Love those roads.
 

·
Registered
Joined
·
1,985 Posts
Hi,

Sounds like the electric centre stand will come in handy when your foot is operational again !.

Maybe the dealer could fix it at a discount as it is an integral part of the bike, unless of course you paid a good price for it.
 

·
Registered
Joined
·
245 Posts
I loved (LOVED) the center stand on mine. I think some have taken there's off as a weight savings. I'd definitely fix it, but if you don't fix it, then definitely take it off - can't remember how much it weighs, but IIRC it's significant (20-30lbs?).
 

·
Premium Member
Joined
·
812 Posts
Welcome to the site. Lots of good helping folks here.

Can't help you with the power stand as I've had an '03 trouble at 150,000 miles, an '02 trans locked up in 4th 149,322 miles and now have another '02 with only 36,000 miles. None of these had the power center stand.

Love the LT model BMW. And do my own work on them. I thought a little unproductive to fix the 2 that had 150,00 miles on them as it much cheaper to find another used one.

Happy riding.

Vern in MO
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,561 Posts
I can help with the center stand actuator just drop me a line when you are ready. I have rebuilt over thirty of the units and I am not that far away. Congrats on the 08 sorry about the foot.
 
  • Like
Reactions: Tricky_dickey

·
Registered
Joined
·
548 Posts
Some things to check:
- make sure the rear brake lights are all good and no LEDs.
- could also be the electronics. They are a small module at the rear right under your seat. (If the troubleshooting come to that, I have an extra module I got from eBay)

Even if the hydraulics are giving trouble, the center stand motor should whine a bit.

Let us know what you find...


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,426 Posts
Some things to check:
- make sure the rear brake lights are all good and no LEDs.
- could also be the electronics. They are a small module at the rear right under your seat. (If the troubleshooting come to that, I have an extra module I got from eBay)

Even if the hydraulics are giving trouble, the center stand motor should whine a bit.

Let us know what you find...


Sent from my iPhone using Tapatalk
Isn't it only the center bulb that can't be an LED? I don't think it cares about the outer 4 but god point.
 
1 - 8 of 8 Posts
Top