BMW Luxury Touring Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just finished rebuilding a salvage 2007 LT. It required a new dash unit. The bike turned out great but I have 2 systems which don`t work--the radio and the cruise control. A couple of people have told me that when you install a new electrical component(the dash) the computer will not recognize it and that to solve the problem the factory in germany has to send a program for that vin # which the dealer downloads into the computer. Any comments will be much appreciated. :confused:
 

·
Registered
Joined
·
2,746 Posts
The Germany supplied number peculiar to the VIN # is for the alarm system. (?) My guess for the cruise control not working is one or more of the switches for dis-engaging the CC is/are not working or out of adjustment. CC on/off, Set, Front/rear brake, clutch, and the throttle works it's way in there too.

You want to get this feature fixed. Awesome cruise control.

Loren

bikefalcon said:
I just finished rebuilding a salvage 2007 LT. It required a new dash unit. The bike turned out great but I have 2 systems which don`t work--the radio and the cruise control. A couple of people have told me that when you install a new electrical component(the dash) the computer will not recognize it and that to solve the problem the factory in germany has to send a program for that vin # which the dealer downloads into the computer. Any comments will be much appreciated. :confused:
 
1 - 2 of 2 Posts
Top