BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
I know this has been discussed many times before I have read most post from the other forum. I decided to go with the aux cable from Bavarian Autosports that others have used oh ya I have 2004 with the CD changer and a single disk.

I received the catalog and seen a IPOD to BMW car stereo interface so my pee brain logic told me that should work as well remove the 6 diskchanger and Install this interface and all should be good.

I received the interface and hooked it up things looked good the IPOD will not talk to the radio head unit called tech support not much help. Has anyone tried and been able to make this combination work

I was just looking for a way to get the use of My Ipod with out removing the tupperware and the radio I have seen the post on what needs to be done looks like a ton of work.

I am new to the LT I love the ride and handling but beginning to wonder if its worth the pain in the ass. I have had to do more little stuff with this bike in 2 mos than I have with my last in 3years, Ground issues with the headlight then I did the HID upgrade that was not to bad but still have grounding problems the no radio problem squeegee brakes and all the post about rear drive failure clutch and on and on. Things just seem to be a pain with this bike nothing easy.

I am venting I know most have felt the same or heard all this before Iam one that will mostly read all the post and just ride the bike and enjoy but I have never read so many bad things about one machine in my life.i have already getting that bad feeling that I made the wrong discission

Thanks go ahead and let me have IT

Vano
 

·
Registered
Joined
·
210 Posts
Did you buy the Dice Electronic unit? I have an '03 and installed the interface a few weeks ago and have been very pleased. Also you need to remove the fuse to your radio unit to get the interface to initialize. If you remove the fuse wait a few minutes and then put the fuse back in, all should be good. You can PM me if you need further help. Good luck
 

·
Registered
Joined
·
208 Posts
I dont have to

remove any fuses...But typcially what i have to do is make sure the IPOD is OFF. Make sure the IPOD is not set to protected mode so the keys can be accessed. Turn on Ipod, Turn on Stereo. All works well.. It took me a long time to get this sequence going. I usually had the ipod on protect mode and it would go asleep during init phase.

2004 k1200 lt, dice (newer gen), ipod 4g
 
1 - 3 of 3 Posts
Top