BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I purchased a 2006 K1200LT about three weeks ago and I love it. However, my hydraulic center stand recently stopped working. The dashboard light for the kickstand flashes at the normal rate for deployment when I press the button, the stand makes a clicking sound but does not deploy.

First, has this happened to anyone and if so what was the resolution?

Second, If the stand needs to be replaced, can anyone recommend a trusted, non-dealer, option?

Any assistance you can provide will be very appreciated.

Thanks,

Jose Beiro
[email protected]
 

·
Premium Member
Joined
·
1,595 Posts
Jose,

Yup it happens. :(
Scroll down to the bottom and you will see a Simular Links section, should help start you out. :)
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,411 Posts
If you want to pull it off and send it to me I will clean it and replace all seals and refill it with proper oil. I will test it on my bike and return it. PM me for details. I also have spare motors on hand.
 

·
Premium Member
Joined
·
2,086 Posts
jzeiler said:
If you want to pull it off and send it to me I will clean it and replace all seals and refill it with proper oil. I will test it on my bike and return it. PM me for details. I also have spare motors on hand.
That is a good idea John.
Or he could come to the Houston tech session next month which is about 5-10 miles from him and we can fix it then. Oil,seals,motors on hand.

Dan Martin
 
1 - 5 of 5 Posts
Top