BMW Luxury Touring Community banner
1 - 9 of 9 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
I have a 2005 LT with a HID light installed by the dealer about 5 years ago. I understand that it takes a few seconds for the HID light to turn on, but lately it's been taking upwards of a minute or 2. Can anyone advise - is this just a loose wire, or the sign of a failing lamp? Whatever advise you have would be appreciated...thanks!
 

·
Registered
1999 LTC
Joined
·
14,460 Posts
sogen said:
I have a 2005 LT with a HID light installed by the dealer about 5 years ago. I understand that it takes a few seconds for the HID light to turn on, but lately it's been taking upwards of a minute or 2. Can anyone advise - is this just a loose wire, or the sign of a failing lamp? Whatever advise you have would be appreciated...thanks!
Doubt it's a loose wire, butt several folks have diagnosed the situation as a failing ballast - even tho they have a history of sudden failure more so than lingering problem.
 

·
Registered
Joined
·
2,763 Posts
Just for grins (grimaces) I was cruising through a parts breakdown for my BMW car and discovered that the ballast for the OEM HID system was $547 and change. The point here? If your system is BMW you might just want to replace the whole thing with an aftermarket system.

Loren
 

·
Premium Member
Joined
·
1,595 Posts
The 2005 didn't come with HID so it is an aftermarket one... Not hard to replace, look up under the nose and you will be able to see the wiring and balast.
 

·
Registered
Joined
·
3,525 Posts
Still, The DDM kits are so inexpensive.. Replacing the whole thing might be the smart move..New digital ballasts and all....

John
 

·
Registered
Joined
·
3,089 Posts
johnbaker15 said:
The 2005 didn't come with HID so it is an aftermarket one... Not hard to replace, look up under the nose and you will be able to see the wiring and balast.

Not hard to replace?

Dude! Have seen installations that almost requires removal of the entire fairing just to find it.
 

·
Enjoy The Ride
K1300GT K1200LT
Joined
·
4,103 Posts
gunny said:
Not hard to replace?

Dude! Have seen installations that almost requires removal of the entire fairing just to find it.
+ 1 Gunny, I remove my nose cone to replace mine I figure at least 4 hours. Both of my ballast are mounted to the cruise control.
 

·
Premium Member
Joined
·
1,595 Posts
saddleman said:
+ 1 Gunny, I remove my nose cone to replace mine I figure at least 4 hours. Both of my ballast are mounted to the cruise control.
Thats because you don't have a 05...the OP said he has a 05 :)

With an 05 the high beam housing makes a nice shelf to mount the ballast onto, only had to drill a hole for the wires. I didn't bother replacing the high beam as the HID light up the night. ( except those tunnels on the Blue Ridge Parkway )

All done without taking one piece of tupperware off, just reach up under the nose. :)
 

·
Premium Member
Joined
·
1,428 Posts
In all fairness to the OP... I've expereinced the same issue. Every blue moon (not the beer) my Aftermarked HID took a bit longer to light up... About two blocks down the road....

As for the installation. if you follow the directions.. yeah, its easy enough.. Don't and you'll be like me... 2-3 hours.. lol
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top