BMW Luxury Touring Community banner

1 - 12 of 12 Posts

Registered
Joined
6 Posts
Discussion Starter #1
Hi i got my dream bike finally K1200LT 2000r
The person i got from was tired of fixing this problem and he gave up !!!
basically when the engine run i select a gear and the same moment the engine cuts off 馃槻馃槓
The side stand switch was already replaced and the clutch switch to
nothing deferent when the bike is on gear and i switch the ignition then the fuel pump doesn鈥檛 work then on NEUTRAL all works and bike start fine !
The other problem is the reversing gear doesn鈥檛 work !
any suggestions ? many thanks
 

Wrencher Extraordinaire
2005 K1200LT
Joined
13,940 Posts
Sounds like a few loose connections to me. The neutral signal goes through the reverser controller. Check these two barrel connections to make sure they are good. Disconnect and re connect a few times in case there is corrosion. If that does not fix it then there could be damage to the reverser controller. I have found them on e-bay for $35 to $100 from wrecked bikes.
 

Attachments

Registered
Joined
6 Posts
Discussion Starter #3
so i did check all the connections and doesn鈥檛 look like there is any issue i took off the reversing module looked around open inside and all look fine
but the problem is still there and reversing still don鈥檛 work
 

Wrencher Extraordinaire
2005 K1200LT
Joined
13,940 Posts
Check the three big Black, with yellow stripe, wires. Each has a colored sleeve at the eyelet, Black goes to the starter tie point, red goes to battery + and brown goes to the ground tie point. Usually when the reverser controller blows that black goop in side comes outside.
 

Registered
Joined
6 Posts
Discussion Starter #5
I checked all and all connected the power go in to the controller and and all look totally good like ever was any problem 馃槓
i disconnected the gear sensors and hotwire the all 5 cables the computer think is on neutral and when i select gear is all fine so i can ride
dose that got any sense ?
what else i should check or replace it ?
thanks
 

Wrencher Extraordinaire
2005 K1200LT
Joined
13,940 Posts
Your hotwire just treats the symptom, the cure is in the side stand circuit and the reverser controller. The reverser controller controls the engine electrics relay which kills the engine. It responds to the side stand signal and the kill switch signal along with the gear indicator and drives the engine electronics relay. Does the kill switch kill the engine? It is an over ride for all the other inputs to shut off the engine. If it does not work then there is a fault in the reverser controller and you already said it will not reverse. I recommend you replace that.
 

Registered
Joined
6 Posts
Discussion Starter #7 (Edited)
the switch kill the engine no problem at all there, the side stand switch got 3 cables red-white-brown at the conector there is 3 go in to 2 the white and brown i check them and is working on and off when i move the side stand to make sure 100% i hotwire them u can see on picture. The motor starter works perfect the switch to start and cut off i put one picture of the reversing module, i will try to take out and see the condition of the speed sensors what is on right side of the gearbox maybe there is some issue
thanks
 

Attachments

Wrencher Extraordinaire
2005 K1200LT
Joined
13,940 Posts
Have you tried hooking the red and brown wires together instead of the white and brown? My diagram shows that as a closed circuit with the stand up.

Your module looks very good inside so it may be OK.
 

Wrencher Extraordinaire
2005 K1200LT
Joined
13,940 Posts
I am giving you a snap shot of the side stand switch wiring to the controller so maybe you can trace the wire from the switch to the pin 4 on the controller and see if there is continuity.

So what happens if brown and white are disconnected? Does it matter at all in your case? Either way as best I can tell the kill switch and the side stand switch both go into the reverser controller and the reverser controller controls the Engine Electrics Relay.

I must revise what I said about the kill switch. It controls the Emergency Power Cut Off relay and that relay removes power from the Engine Electrics relay. It does not go through the reverser controller. The controller removes the ground to the Engine Electrics Relay. So either one will kill the engine.

Now we need to figure out why yours works the way it does.

OK I added more diagrams of where the gear position comes to the reverser controller.
 

Attachments

Registered
Joined
6 Posts
Discussion Starter #11
hi that鈥檚 my last post 馃槉����������
how i say before everything on this bike work and i did found the problem 馃槉
someone instal datatool alarm to it and the alarm didn鈥檛 connect some cables so i disconnected and put how originally was and bike works perfect included the reversing gear
massive thanks for your support
thanks
 

Wrencher Extraordinaire
2005 K1200LT
Joined
13,940 Posts
Glad you figured it all out, I guess I should have asked if an after market items had been installed as that usually does cause problems. Now enjoy the LT she is a very nice ride.
 
1 - 12 of 12 Posts
Top