BMW Luxury Touring Community banner
1 - 9 of 9 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter · #1 · (Edited)
I'll keep this short. 02 ltc , 65000 miles, 20000 are mine in the last year.Handed an extra fuel filter when I purchased it from the dealer. Given by previous owner. I take care of the preventative maintenance myself.
Last week she stall twice as though it wasn't getting fuel, and then again today . I had more trouble today the the other. Very hesitant idle and would stall ,or all smooth.
. I also noticed that my gas mileage has dropped from 44.5 to @ 40.

. Ideas, suggestions ? Thanks
 

·
Registered
Joined
·
47 Posts
sounds similar to The problem I had try some bmw engine cleaner. Did you say you just replaced the fuel filter? If so check your fittings make sure they are tight sometimes the hoses are not tight enough inside the tank and can cause less fuel pressure.
 

·
Premium Member
Joined
·
4,886 Posts
I put off changing my fuel filter because I was busy changing clutch, slave, seals, seats, springs, and on and on.

I recently had the tank off to install front shock, and wile I was in there I changed the fuel filter. Around 32k on this '05, could be the original filter (have not checked history of late), and after the new filter was in, my average fuel economy seems to have gone up by about 7-10 mpg per the BC. On the highway, it is even higher.

Not that the filter is the problem, but it may make a difference and be part of the solution.
 

·
Registered
Joined
·
5 Posts
Just changed my fuel filter. I only had 7 or 8 thousand mile on it and I could barely blow through the damn thing. Engine started hesitating at 2K rpm. Also found the distributor pipe or breather pipe had cracked and leaned out my mixture. Put it all back together and replugged the Temp sensor that i used to richen the mixture up before I found the problems. Old girl runs great now and can't wait to check my fuel mileage again. :dance:
 

·
Registered
Joined
·
6,285 Posts
mamie said:
Just changed my fuel filter. I only had 7 or 8 thousand mile on it and I could barely blow through the damn thing. Engine started hesitating at 2K rpm. Also found the distributor pipe or breather pipe had cracked and leaned out my mixture. Put it all back together and replugged the Temp sensor that i used to richen the mixture up before I found the problems. Old girl runs great now and can't wait to check my fuel mileage again. :dance:
Glad you got it fixed, but not being able to blow through the fuel filter doesn't mean a thing... the crack in the pipe was most likely the culprit.
 

·
Premium Member
Joined
·
3,108 Posts
Check to be sure your charcoal cannister is not clogged. Just unscrew the gas cap after riding an hour or so and listen for any vacuum noise. If you have it, that's bad. Also check for a cracked fuel line in the gas tank.
 
1 - 9 of 9 Posts
Top