BMW Luxury Touring Community banner
1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I decided take to take off the Tupperware to have the bike painted. While that was being done I checked the valves and noticed they needed to be adjusted. Having the valves adjusted is a little beyond my expertise so it decided to schedule appointment with BMW of Charleston while there I told them to flush the brakes, the clutch and changed the fuel filter. They came to me later that afternoon and asked me if my bike idled low. Went to the back and noticed that the light was idling very low and Shutting off. after they examined it for a while noticed when the vent hose's was kinked. The bike started idling fine. I loaded my bike up on the trailer. Decided to start it to see how it idled. Did not idle well and kept shutting off. They came out took the gas tank out off the bike and put new hoses on the inside where the filter is.started the bike and it idled a little low but ran. When I return home(100 miles away) the bike would not even start. I talked to the mechanic he said that he believes that it's the throttle body actuator. He said he did get the code on it when it first arrived but could not get the code back after reset. I spent $527 and the bike running fine when I arrived at the dealership and left from there now it does not run. Now they want me to spend another $250 on the actuator plus installation. The battery was disconnected and I did the throttle reset when I got home. He said he did check filter to make sure it was not on backwards. he did check the timing and the valves twice to make sure that was not the problem. do you have any thoughts on what it might be before I take it back?
 

·
Premium Member
Joined
·
3,549 Posts
Unfortunately I cannot help you trouble shoot. But, there are 3-4 actuators on eBay from $25 to $75 for one from a 09.

There isn't a way to "adjust" the valve clearance. There are “buckets” of varying thicknesses which are used to bring the gap into spec.

If they didn't have to either move or change any of them then the area to look at is what needs to be done to remove the fuel tank, installing a new filter, and installing the fuel tank.

Here is a thread with similar problems:
http://www.bmwlt.com/forums/showthread.php?t=69972&highlight=fuel+tank+hose

Another with different possible causes:
http://www.bmwlt.com/forums/showthread.php?t=67789&highlight=fuel+tank+hose

Here is a different cause and solution:
http://www.bmwlt.com/forums/showthread.php?t=67831&highlight=fuel+tank+hose

A similar thread with “Is there enough gas in the tank?” I seem to remember that the sending unit for the amount of fuel in the tank can be mis handled:
http://www.bmwlt.com/forums/showthread.php?t=65133&highlight=fuel+tank+hose

Canister removal:
http://www.bmwlt.com/ubbthreads/sho...er=159072&page=0&view=collapsed&sb=5&o=0&vc=1

I found those threads by using the “search this Forum” function which is in the upper right hand side one the first page of the LT forum.

Once you find a similar thread if you look at the bottom of the page you will see similar threads listed.

My uneducated reaction is that all of the hoses and connectors should have been inspected when they changed the fuel filter. Going back and replacing the hoses inside the tank puzzles me? Changing them without solving the problem?

One of the best tips I've seen is to document what you test—I'm forgetful.

Best from Tucson
Bob
 

·
Premium Member
Joined
·
4,886 Posts
+1
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 ·
deanwoolsey said:
I bet your fuel hose in the tank split. Common problem. Open the filler and look inside the tank while turning on the key. See any fuel moving around or spraying?
the inside fuel hose was replaced at the dealership and I also checked it when I arrived home. I am thinking maybe the fuel regulator I have one coming in on Thursday. If not that possibly fuel pump itself is not putting out enough pressure .
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top