BMW Luxury Touring Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Two questions, one.. my battery got low since I haven't started it in about 6- 8 weeks. charged it this morning and now it won't start? Everything powers up, but it is acting like the side stand is down. Nothing happens when the ignition is pressed. How does one check the kill switch on the side stand?
My second question is the automatic locks work, but the glove box one is stuck locked. has anyone had to solve that problem? thanks
 

·
BMW Guru
Joined
·
8,469 Posts
veryneil said:
Two questions, one.. my battery got low since I haven't started it in about 6- 8 weeks. charged it this morning and now it won't start? Everything powers up, but it is acting like the side stand is down. Nothing happens when the ignition is pressed. How does one check the kill switch on the side stand?
My second question is the automatic locks work, but the glove box one is stuck locked. has anyone had to solve that problem? thanks
Sounds like your alarm auto-armed.

The glove box lock has been known to stick. Might need a trip to the dealer for that one...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Tryed the alarm and locks and it doesn't seem to help with getting ignition or any starter activity??
 

·
Premium Member
Joined
·
7,565 Posts
Are you sure the bike is in neutral? I know, obvious question, but sometimes we miss those.

AS for the glove box, yes, they do. It happened to me and the dealer hd to short the connection to get it unlocked. Got it replaced under warranty.
 

·
Registered
Joined
·
440 Posts
If you push down on the unlock/lock button for the lid at the same time you push the unlock button on your FOB it will sometimes unlock the lid.
 

·
Cooler on the east coast!!!
Joined
·
1,243 Posts
Sorry to hear about your problems. I had trouble after my battery go low and could not start my bike but nothing worked after charging the batttery. I had to get the alarm reprogramed. Sorry can not be of any help.
Good luck.
 

·
Registered
Joined
·
1,191 Posts
I haven't messed with my battery on my 05.

One of the stupid things I did was accidently hit the the handle bar kill switch. Took me 5 or 10 minutes.

Go through the simple stuff first.

You said the locks open and close, does the alarm work? Can you get it to arm, sound the alarm, then clear? If so, I'd assume it works fine.

Check reverse as well.

Joe
 

·
Registered
Joined
·
293 Posts
I believe that if the battery is below 80% of capasity it will fire everything up but refuse to start. Happened to me after I forgot to switch the GPS off. A small push start and it worked.

I have now bought that darn expensive BMW Battery Tender and the bikes takes turns on it every 5 days.
 

·
Registered
Joined
·
3,208 Posts
Before you haul her down to the dealer, try to disconnect the positive leads to battery for around ten minutes, it worked for me!
 

·
Registered
Joined
·
609 Posts
BTW-
I haven't had an opportunity to ride in awhile (Howard may disagree :D :D )
so my dead LT took about 15 minutes on a standard (read cheap) charger and fired well..........it's an 05 and seems to suffer battery death-especially when me and my 2 yr old grandson play on it w/some power initialized!!!!!

MORAL......don't be a stupid papa and guide them from their Dad's HD by showing them all the cool stuff on our Beemers!!!!!!! :) :)

Mike
 
1 - 10 of 10 Posts
Top