BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,104 Posts
the most likely problem is that your fuel sending tube is bent and the float that runs up and down it cannot go the entire way. This can be fixed by removing the unit, and running a socket down the inside of the tube if it is not bent too bad, to straighten it out.
Your tank has either crushed your unit due to a clogged cannister or you bent it with a fuel nozzle.
 

·
Registered
Joined
·
4 Posts
Make sure you are on the side stand when you are fueling, because if you are on the center stand the tank will not fill all the way full.
 

·
Premium Member
Joined
·
1,414 Posts
If you do a search, under the K1200LT forum, for "Fuel Gauge" you'll find an extensive amount of feedback about your issue. Also, see the "Similar Threads" below.

HTH,
Jer
 

·
Registered
Joined
·
87 Posts
Both my k1200RS and my k12LT have the same issue after filling up. I thought that malfunction was part of the bike! Every now and then I get a full register when I fill!
However, for me its not worth paying 3 hours worth of labor to find out if the gauge is stuck.
 

·
Premium Member
Joined
·
1,414 Posts
BMWrdr said:
Both my k1200RS and my k12LT have the same issue after filling up. I thought that malfunction was part of the bike! Every now and then I get a full register when I fill!
However, for me its not worth paying 3 hours worth of labor to find out if the gauge is stuck.
A good time to check it would be when the tank is off for either a fuel or air filter change.

Just my $0.02,
Jer
 
1 - 8 of 8 Posts
Top